TREK Demo project compile error

HI
I used TREK demo project(DecaRangeRTLS_ARMCubeMx_2p25) to debug the board. I do not generate the project by CubeMx, just import the demo project into SW4STM32. When I compile the demo project , the project failed.
The detail as following:

make all
Building target: libTREK1000_CubeMx.elf
Invoking: MCU GCC Linker
arm-none-eabi-gcc -mcpu=cortex-m3 -mthumb -mfloat-abi=soft -specs=nosys.specs -specs=nano.specs -u_printf_float -shared -T"…/STM32F105RCTx_FLASH.ld" -Wl,-Map=output.map -Wl,–gc-sections -lm -o “libTREK1000_CubeMx.elf” ./uwb_3.8.si4project/Backup/deca_spi(6029).o ./src/usb/deca_usb.o ./src/platform/deca_mutex.o ./src/platform/deca_range_tables.o ./src/platform/deca_sleep.o ./src/platform/deca_spi.o ./src/platform/port.o ./src/decadriver/deca_device.o ./src/decadriver/deca_params_init.o ./src/application/dw_main.o ./src/application/instance_anch.o ./src/application/instance_calib.o ./src/application/instance_common.o ./src/application/instance_tag.o ./src/stm32f1xx_hal_msp.o ./src/stm32f1xx_it.o ./src/system_stm32f1xx.o ./src/usb_device.o ./src/usbd_cdc_if.o ./src/usbd_conf.o ./src/usbd_desc.o ./Middlewares/ST/STM32_USB_Device_Library/Core/Src/usbd_core.o ./Middlewares/ST/STM32_USB_Device_Library/Core/Src/usbd_ctlreq.o ./Middlewares/ST/STM32_USB_Device_Library/Core/Src/usbd_ioreq.o ./Middlewares/ST/STM32_USB_Device_Library/Class/CDC/Src/usbd_cdc.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_cortex.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_dma.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_flash.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_flash_ex.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_gpio.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_gpio_ex.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_pcd.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_pcd_ex.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_pwr.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_rcc.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_rcc_ex.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_spi.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_spi_ex.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_tim.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_hal_tim_ex.o ./Drivers/STM32F1xx_HAL_Driver/Src/stm32f1xx_ll_usb.o ./Drivers/CMSIS/Device/ST/STM32F1xx/Source/Templates/gcc/startup_stm32f105xc.o ./.metadata/.plugins/org.eclipse.cdt.make.core/specs.o
c:/ac6/systemworkbench/plugins/fr.ac6.mcu.externaltools.arm-none.win32_1.16.0.201807130628/tools/make/sh: syntax error: unexpected “(”
makefile:43: recipe for target ‘libTREK1000_CubeMx.elf’ failed
make: *** [libTREK1000_CubeMx.elf] Error 2

I already added the weak and the packed symbols as the attached picture.

I find someone fixed the issue by add the weak and the packed symbols, but I do the same ,it does not work. Should I right it in the process ? If so how do I configure the project to fix the problem?

Thank you in advance.

The 2 documents attached should be of a help
/Leo

01_InstallationOfTheToolsAndDrivers.pdf (805.2 KB)
02_PortingToSTWorkbench.pdf (1.1 MB)