Can't get UART prompt

I have installed the JLink Segger .deb in a RaspberryPi 3B and ‘miniterm /dev/ttyS0 115200’ does not give a prompt. Is this expected behaviour?
Kernel commandline sends “console” to tty1 and I also tried to disable bluetooth and read from AMA0.
How can I connect like in the User Manual (page35)?

Which board are you using ? ( DWM1001 / MDEK1001 / DWM1004 / custom). If you are using MDEK1001 FW2 you need to hit enter twice quickly.
Maybe this can help: MDEK1001 - Return Key not working as command in Tera Term as Decawave's User's Manual states

It is an MDEK1001 and it is set as tag. The answer you point me to, does it say I have to set up the network with all nodes for the prompt to come up? I have double pressed ‘Enter’ I cannot do it faster.

I solved the issue. According to the pinout of MDEK1001’s J10 module in the datasheet, 8=Tx and 10=Rx, Raspberry’s pinout is 8=Tx, 10=Rx and I had connected Tx -> Rx. I switched Tx->Tx and Rx->Rx and I can see the prompt with a simple:
screen /dev/ttyAMA0 115200 or miniterm /dev/ttyAMA0 115200

Perhaps a typo in the manual or I misinterpreted? The MDEK1001 manual does say to connect the USB table and open TerraTerm.