MDEK1001 - Return Key not working as command in Tera Term as Decawave's User's Manual states

The Step 7 works fine but for most Windows PC, the Return Key is not accessible.

I have tried pressing the Enter Key twice again, which is mostly often the Return Key and it doesn’t work.

The Step 8 below is the problem in my case.


I have tried the ASCII, the Unicode and the C programming language equivalent for the return key and it still doesnt work.

If the mode of the node has changed can be checked at this point with for example asking for system information “SI”. Best maybe toggle between nma (+2x enter) and nmt (2xEnter) to see if it has changed.

For LES to work you’ll need a couple of nodes to work, eg an intiater, 3 anchors and a TAG to show ranging distances.


Hi Leo,

Thank you for the response!

I do have 4 anchors with 1 initiator, a Tag and also a Listener.

I tried the commands you specified and here is what I get.



I have 5 nodes here.
I powered 4 nodes, and with using the APP on my android phone. Then I created a network and added these 4 nodes. Then I configured these 4 nodes as three Anchors and 1 initiator . I enabled UWB on each of them also.
Then I powered the 5th node through usb to the laptop. Again using the android app I added it to the network and enabled UWB.

I started Teratem (speed 115200) , enter 2x , typed LES . And after 2-3 seconds I started to get all the data. So my question. Would you have enabled UWB on your devices?


Hey Leo,

I thought the nmt was going to prompt a response in Tera Term. It doesn’t. It only reconfigures the tag/listener as a tag or anchor. This was not explained in the steps of the user manual and the nmt commands only leads to confusion as it is NOT a necessary step to get the position data in Tera Term. This is a step to configure the Tag.

Yes, the LES function works. It always has as I indicated in my original post.

The Return key does not exist on keyboards that are not Apple computers. It is often replaced by Enter. In the User Manual, Enter is mentionned above in step 7 but then is changed to Return Key on step 8. This leads to confusion also.