UWBMAC uwbmac_init() returns "Protocol not supported"

I’m porting Qorvo Nearby Interaction example to single core STM32H7 microcontroller, and I’m running into problems while initializing the uwbmac. It always returns -22 (Protocol not supported). I’m using it with a DWM3000 v1.4 module (non PDoA, ‘deca0302’ ), which I know works, because I have the modified example also running on nRF52840.
I am not able to trace the source of the problem myself, there are so many factors, plus there is no source code for uwbmac. To make it even worse to diagnose, the port is not complete. For instance I don’t have BLE implemented yet, NVM storage can’t be rewritten, it’s a Cortex M7 (barrier problem?, are M33 files also available?) not M4. I’m running the init from fira niq helper…<- this I tried also on Nordic SoC in Default task, and it initialized successfully.

Does anybody know what could possibly cause this error? What needs to be setup, to successfully initialize uwbmac? If someone could steer me to the right direction, I would be very thankful :slight_smile:

I’m using STM32H723, FreeRTOS cmsis v2, UWB-Stack R11.9.2, dwt_driver 6.0.14, I can give more details later.

Thank you guys!

Hi, I have the same issue with you, still no reply and unsolved, my BLE chip is Cortex-M4F: Nearby project uwbmac_init return UWBMAC_EPROTONOSUPPORT

1 Like

For UWB stack to initialize without the “protocol not supported” error, the crypto functions in mcps_crypto.c must work. Completely - meaning, when there is some kind of crypto error, it has to return the correct one (more in “nrf_crypto_error_to_std_error” function).
Since I don’t have the encryption module, I’ve used the MbedTLS.

Hope this will help someone.