UART shell mode unable to type normal characters

I’m trying to communicate from a raspberry pi b to the decawave bridge node via UART shell (this is using the minicom command). When I try to type anything, nonsense characters show up, regardless of what key I press. I’ve tried this SSHing in from multiple computers, as well as from a monitor hooked directly to the raspberry pi, so it definitely is not a keyboard issue. I’ve attached a picture from Teraterm, which I’m using to SSH in. Any advice is appreciated!

Hi Clare,

what you see is the response from the UART API. By default the on-module UART interface runs in the API mode. If you want to enter shell then please press double-enter within 1s. It will switch from the UART API mode to UART Shell mode.


I have hit double enter. That will bring up the dwm> line, but I still can’t type. Here’s another screenshot using the raspberry pi’s monitor rather than SSHing in, it’s a similar situation but you can see that the characters coming up when I type are quite strange. IMG_6062

Hi Clare,

Ok I see. When you enter the shell, have you noticed any module reset (e.g. via LEDs blink)?

Can you please check that the UART settings are: baud rate 115200 bps, 8 data bits, 1 stop bit, no parity, no HW/SW flow control?

Have you opened device /dev/serial0?

Please send also a picture of the module with soldering details of the header connector.

Cheers, TDK

We were using those settings, still not sure what was going on.
We’ve ended up switching to using a USB to get the information we need directly from the tag. Maybe not the ideal solution, but it seems to be doing what we need. Thanks so much for your help!