TTK1000 Anchor Debug with eclipse

When I try to debug, problem occurred.
‘Launching anchor_F429_UWB_standalone.elf’ has encountered a problem. Error with command:gdb --version.Cannot run program “gdb”: Launching failed

and then,I tried to setup the Debug configurations like this, but can not see anything in Target information.

Could anyone help me to figure out how to setup the eclipse debug environment? Thanks a lot.

You should NOT go via AC6 STM32 Debugging.
You should go via OpenOcd + GDB route

  1. Google on how-to debug ARM with Eclipse…
  • you need to run openOcd first - you have a cfg script in the root folder.
  • then connect arm-none-eabi-gdb to openocd (port 3333)
  1. TTK1000 is coming with Support hours. You must ask your Field Application Engineer for the support. In which region are you and what is the company name?

Thank you for your advise.
Should I work on it with OpenOCD + GDB like this?
sorry, only one pic can be posted…
but, still can’t enter the main() when I tired to debug with openOCD + GDB.

I’m in Beijing, China, this is Pinefield Tech. My FAE told me that he never debugged with TTK1000 and demand me to ask for help here.


You can’t debug because STWorkbentch complains “The debug configration is not associated to a MCU Project”, it looks like issue here is related GDB settings.

As Alex has pointed this out, you have another issue - "No source available for “0x0"”.
Have you build your elf executable and its dependences with -g option ?

Which TTK1000 version you are currently working on ?

Hi, TaoYuan,
Thanks for your feedback, but still confuse me anyway, would you mind explaining more? Here is my debugger settings.

My TTK1000 version is release1.3, the debug elf is the standalone elf, I followed the decawave doc to make the project build.
BTW, the doc named TTK1000_Anchor_Software_Guide.pdf.

Hi Sanjuegou,

The supporting hourse is overtime , addtionally we gave onsite support for setting up the kit (this is impossible for other customer).

please forgive that we have no resouce/time/duty to support the foundmental issues for startup customers one by one.

Also I suggest that the best way for startup customer is to ask Google/Baidu/… for this foundmental issues (IDE setup/debug tools/compiler setting…).

Best regards

I havn’t use any supporting hours, do you believe that I got any useful informaiton in wechat?
That’s why I am here and ask for help.

Am trying to setup environment and reproduce. If urgent, you can contact me at

Don’t worry, we will fix it.

Thanks a lot, keep in touch. :+1:

There are many ways you can try, this is what I do …
Create a empty Makefile project using System Workbench for STM32, so i do -
go to File → New → Project → C/C++ → C Project, type a new project name, select “Empty project” under the “Makefile project”, choose the Ac6 STM32 MCU GCC, click on next and next … till you see page to select device. On this page, select your target MCU STM32F429ZITx and Board ( i select nothing on my case ) , click on “Finish”.

At the moment, you have created your empty makefile project. You can do
either copy everything directories, Makefile, … from dw_tdoa_anchor to new created empty makefile project but don’t copy 2 project file .project and .cproject,
or copy 2 project files .project and .cproject from new created empty makefile project directory to dw_tdoa_anchor.

Clean up and build TDoA project source, you should not expect to see any issue. Go to debug configuration, now you should see target information from debug configrations page.

Follow your steps, I can see the Debug button is not grey. But still have some issues, I’m going to try other ways.

Please post here your debug configuration page so i can understand the issue.

At the moment it’s OK to launch System Workbentch for STM32 as below.

(1) follow up advices to have MCU Target information shown in debug configuration page, and (2) let “DEBUG = 1” in the Makefile and re-build all anchor source tree, (3) launch debugger as usual.

Try not to specify path manually for ARM tool chain and openOCD, let System Wrkbentch for STM32 to do it.

If you still experience issue, please check at first if openOCD working or not, try:
$ openocd -f interface/stlink-v2.cfg -f target/stm32f4x.cfg

Hope this will help.

It’s done, thanks a lot! :love_you_gesture: