Trouble with DWM1001 SEGGER Programming over USB


We’re trying to establish an SPI connection invoving a DWM1001 devkit module using the nRF52832 IC, and I’ve downloaded the repository file from the Nordic Semiconductor website to work off of the examples provided from there.

In particular we decided to start off by simply trying out one which is supposed to cause the first LED on the devkit to turn on and off every half second (if anyone is familiar with this repository the SEGGER em file is in \examples\peripheral\blinky\pca10040\s132\ses). We were unable to get it working. We are completely new to SEGGER and it’s probably just a matter of us using the code in the wrong way.

I tried “build blinky-pca10040-s132”, and after it was sucessfully built I tried (under “Target”): “connect j-link” and then “download blinky-pca10040-s132”, presumably uploading the code. The LED isn’t blinking, however. Are we missing a crucial step?

Hi @JJennings
your request is more like for Nordic support forum and not Qorvo forum. Im not familiar with your SDK, but there is one common beginners error here. Double check which GPIO is assigned to LEDs, I would guess that this mismatches and that is the reason why you don’t see LED toggling. You just toggling different pin.