Timestep too small

Hi everyone,

I am testing QSpice and I get a timestep too small error when trying to simulate. I have replicated the whole circuit in LTSpice and I do not get an error in LTSpice. What is going wrong?

Here is a Google drive link to both simulations since I cannot post them here:





I was unable to download your files. I don’t feel like registering.

Do you mean registering for google drive?

I am sorry.
That’s the way to do it:

Sure, no problem, here you have the screenshoot.

Oh, I didn’t see you already opened up my files, I guess you registered then :slight_smile:

Thank you. I see you added two options for the solver, can you explain why to me, please?

For some reason, now that I add you .opt parameter the waveform window does not work. I cannot plot any signals.

Correction - the waveform window works its just that the solver takes so long and after a few minutes still gives the fatal error Timestep too small.

Any ideas?

Did you change other settings?

Ahh I see, will try that now. Thanks!

Additionally change the source and remove the resistor

Yes, the issue was in the resistor. Any ideas why?

Hi Samo,

QSpice can simulate the netlist of LTSpice, so I tried it. QSpice simulated your “BipolarHB.net” without the “time step too small” error, but the results were different from those of LTSpice.
The option setting, e.g., “.option reltol=1e-4 abstol=0.1p chgtol=1f vntol=0.1u gmin=0.1p,” made the results a bit more similar, but not enough.
I wonder if we need any additional option settings or netlist corrections for QSpice.

Forum_Qorvo_Somos_HB_QSpice_BipolarHB_LTspice_net.txt (978 Bytes)

I deleted the diodes and switches in QSPICE. I used CRTL+C in the diode and SWITCH models in LTSPICE and CTRL+V in QSPICE.
It worked for me.

You might want a switch that smoothy turns on and off. Give it a negative value for the hysteresis, Vt.


1 Like

Try adding a 10kR or so resistor in parallel with the diodes.