Super basic serial monitor


I’m trying to connect to the DWM1001 chip for the first time using a Mac. I can’t seem to successfully connect to the UART Shell mode. Using the Serial app, I’m trying to send “\r” with the correct baud rate but only “@” displays on the screen.

I’ve tried using Python’s serial library and sending 0x0D to no avail. Am I using the wrong driver or did I skip a step in the setup?

It shows up how you would expect:

J-Link: Product ID: 0x0105 Vendor ID: 0x1366 Vendor ID: 0x1366 Version: 1.00 Serial Number: 000760024898 Speed: Up to 12 Mb/sec Manufacturer: SEGGER Location ID: 0x14400000 / 4

And the driver information:

Name: J-Link #3
Path: /dev/cu.usbmodem1441
USB ID: 1366:0105:0100
Serial #: 760024898
Driver: AppleUSBACM (v5.0.0)
Driver ID:

Do you send “\r” [color=#ff3333]twice[/color]?

I’m curious how this turned out. Im also trying to use a mac.

I’ve tried sending “/r” twice, and the result was, of course, “@@” :at: :at:

I’m using python script to send and receive through UART too, one Tag acts as a Listener. No problem on reading position sent from Listener through UART. However, before that, I have to press Enter twice and enter Command manually. It doesn’t understand “/r/r” as “press Enter twice” on Python script. I tried “/r/n/r/n” too, got same result.

Should I try sending Enter key hex code?

Hey remintein,
Is it possible for you to share the code through which you got this working with Python?