Small improvements in schematics

I’ve started using hierarchical symbols, and I’ve noticed a few things that would be useful.
1/ I’m having to use a Tilde in front of a port label to represent an OVERSCORE (I.E NOT Q). I use KiCad a lot, and it converts a Tilde automatically into an overscore symbol.
2/ I’ve noticed that I’ve had to change port labels in several different places when editing. Could some kind of automatic inheritance be used so that if a port is connected by the same name and the name is changed, then this change is propagated to the other labels as well (maybe with a prompt?).
3/ Maybe an Asterix should appear in front of the UNSAVED schematic sheet in a hierarchical design (again as in KiCad). This way it would be a quick prompt that it needs saving. A warning would also be nice.

  1. QSPICE uses the vinculum character, a character that was used on IBM machines and part of the PL/1 programming language. It otherwise isn’t used anymore, so QSPICE uses it for negation. You don’t have to type it in, just highlight what you want negated and right click=>Invert Overbar.

  2. That might be a future option, but normally one certainly does not want all nets by the same name to change when one of them is edited. That should probably look more like a search and replace option, since nets appear all over, i.e., outside of the context of a wire.

  3. QSPICE already does warn when you close a schematic that isn’t saved. It will not warn if you’ve edited and undone to get back to the version on disk. It keeps that straight.

Thanks, Mike,
I can use the “Invert overbar” command in the child schematic boundary rectangle labels. However, I am NOT able to use this command in the hierarchical symbols in the root schematic. The command is greyed out, and I’m not able to zoom into the individual symbol (I can only use the space bar to zoom into a group of symbols). If I point at the label on the root schematic, a hand appears. If I right-click the “invert overbar” is still greyed out. Am I doing something wrong? Thanks.

Try selecting a region of text.

Still doesnt work. Ive attached a screenshot showing the problem.

Sorry, I meant you have to select some characters to invert the Overbar.

1 Like

Sorted. If I point at the label then right click and select “edit pinlabel” and then place the cursor at the end of the text and then press SHIFT and move the cursor over the text I want to select I can then right click and select “invert overbar”. Easy when you know how. Thanks Mike.