Singular matrix warning on simple passive RF filter

I’m getting a “Singular matrix” warning on a pretty simple bandpass filter circuit. I get the warning, and the results do not look accurate. The same circuit worked on LTspice. Any ideas on what I’m doing wrong, or is it a possible bug.

The update rate on Qspice is very impressive!

Download the Qspice circuit

If this doesn’t work, try to update Qspice. Also, I removed the figures to save space.

Best regards

bpf-100-120_V2.qsch (6.9 KB)

I’ll download and see what happens. I was using the version that was generated 16 hours ago.

What did you do to too make it work?


I added gmin=1e-20, to increase Rpar of inductor. To see parameters of inductor
point on inductor → right click → Pertinent help file page → check parameter Rpar

Best regards

Thanks Ivan,

It worked. I also see you moved the “AC 1” to a separate attribute of the voltage source and that was also required to make it work.

Having come from LTspice where that was a checkbox on a GUI, it wasn’t clear that it needed to be a separate attribute.

Thanks again!

Why aren’t you doing, what did Qspice suggest - set GSHUNT?

I am doing as Ivan suggested and setting GSHUNT and also moved “AC 1” to a different attribute. Both were required for the circuit to work correctly.