Setting output impedance (ROUT) of Ø-Devices to 0 not working

Since this is my first post here, I would like thank you so much for making Qspice available for free.

Now to my question: I’ve been playing around with Ø-Devices and trying to set the output impedance (instance parameter ROUT), which works, except for setting it to zero, which seems to do nothing. I have to set it to 1e-308, which is probably good enough, but being able to set it to actual zero would be nicer.

The output is going to be a Norton equivalent circuit. It’s impedance can not be zero. QSPICE is trying to be polite by ignoring a request to set it to zero.

Norton equivalents are always preferred in circuit simulation because of the way the rest of the circuit is represented.

1 Like

Thanks for the explanation!

Would it make sense, if Qspice internally round ROUT to the minimal supported value, when user sets ROUT=0?

Setting it to the minimum supported value or printing a warning would probably be more user-friendly than just quietly ignoring it.

1 Like

At 0°K all molecular activity stops, using numbers below this may be science, but not engineering.