Running Deca Ranging program

I am trying to run the Deca Ranging program to see the channel impulse response.

Here is my setup: Windows 7 Professional, 64-bit

I followed the Ranging Demo PC User Guide instructions exactly.

I installed the Virtual COM drivers:
for Windows 7 64-bit
and the Microsoft C++ 2010 x86 libraries:

I’ve plugged my EVB1000 into my computer. It is powered up. It is in anchor mode. So for switch S1 only switches SW1 and SW4 are on.

I have another EVB1000 nearby powered by a USB charger with SW1 of switch 1 on only so it is in tag mode.

Both tags are displaying their distance from each other in meters.

I can see the the STMicroelectronics Virtual COM Port on COM22 of my device manager, so it seems like the driver is isntalled.

However when running the Deca Ranging exe I get a message stating:
ERROR - Cannot open a cheetah device or connect to EVK1000 over COM port

What is going on? I tried this on Windows 8 too.

Does anyone know what the problem is here?

Is the EVB1000 (the one plugged into the PC) in the USB2SPI mode?

switch S1 - 3 OFF on EVB1000 - for EVK application , (SWs 1 - 4,5,6,7 ON on EVB1000 for TREK appliction )


By default my boards came with V 2.10. The TREK application works perfectly with this, but the Deca Ranging application does not.

When I flash the latest Deca Ranging 3.05 application to the boards, the Deca Ranging application works, but the TREK 1000 application does not.

Is this normal behavior? If not how can I get the TREK 1000 application to work with the latest 3.05 .bin files.

This is normal behavior. You cannot range between TREK ARM tag application and DecaRanging PC anchor. The TREK tag timings are optimised, the turnaround times are too quick for the PC application.

If you need an ARM application tag, then you must use EVK1000 ARM SW in the EVB1000.


I am just getting started on EVK1000 and I have the same issue.

“When I flash the latest Deca Ranging 3.05 application to the boards, the Deca Ranging application works.” Could you elaborate on this? I would like for Deca Ranging application to work, so how do I go about this?

Thank you!


I tried to run the DecaRanging program, but I got only the splash screen, nothing else. For several minutes. No error messages or log files are shown.

COM port drivers and VC2010 are installed…
I have tried with both the anchor and the tag, switch to USB2SPI mode.

Any advice for this problem?


What Software version is on the boards? It will tell the version when resetting the board on the LCD. is it version 2.35, 3.05 or 2.10
Also what version of the PC Decaranging are you using? 3.05 or 2.58.
And when you connect the EVB1000 to the PC are the drivers installed? (see device manager ports (COM & LPT)

Hi please make sure, that the tag and anchor are using the same configuration, eg, speed rate, channel…, as the decive connected to the PC will get a default configuration automacally, so the other one should by troggling the corresponding switch get the same configuration.