QSpice will no longer install

I installed QSpice for the first time on my work computer about 3 days ago. Works!!! Thank you. :grinning:

Today when I entered the program it says: Update available.

I downloaded and began to update.

The update failed with an error message. :neutral_face:

When I entered QSpice again, items such as models and the demo examples where no longer there. :face_with_raised_eyebrow:

I uninstalled QSpice.

I executed the QSpice installer.- It proceeded the install process then failed. with the error:
“Could not install the file C:\Program Files \QSpice\SetupHandlerDLLs.exe”


The installation aborted. Now I can’t get QSpice back on my computer. Apparently there was an update build made on Aug 17.

Is there a way to get back to an earlier version that would load and work?


Update: I just got QSpice to install again. It appears to be working … kind of.

In my previous post, I got update and installation failures. I would always update/install via the “System Admin” profile which I have authority to perform. I would get fails during the update or installation process.

However, I went back in to reinstall QSpice user the “Local User” profile. It installed. :grinning:
It appears to be working now. All the installation files appear to be there. There was one warning/complaint about a feature that could not be installed with System Admin privileges but all seems to be operational for now.

I wasn’t able to duplicate this.

It’s good news that the user-mode install worked. The error window should have just said that you can’t install the Windows extension that enables schematic & symbol previews in File Explorer.


Although I did get it to work-ish.

Yes. The warning window that appeared in the installed indicated that the schematic and symbol previews feature could not be installed without Sys Admin privilege.

Recently I tried to run the "C:\Program Files \QSpice\SetupHandlerDLLs.exe” as “Administrator”. It failed.

QSpice was installed on my work computer. I don’t have “absolute” Admin privileges but I received secondary Admin privileges to load applications. This is company policy.

If ‘absolute’ Admin privileges are required to install any features, I have to request special temporary access.

Two notes.
Note 1:
When I first installed QSpice that was successful, I believe I used “Sys Admin” access.

Note 2:
I have full schematic and symbol preview access on my home computer. On this computer I have ‘absolute’ Sys Admin access.



Is there additional information I might be able to acquire to shed more light on this issue?



Update: I tried to install the latest build (Oct 19 2023). I now get an error thrown by the virus detector program being used which is Cortex XDR.

Hope this helps.

When I update on my personal computer, my virus program doesn’t complain.

Additional observation: When I try to pause updates (“Pause for 3 weeks” for example), it doesn’t work. The next day it asks again.

FYI It also happened to me with several updates. Local user profile was the only way. :thinking:


Thanks for the reply. Actually I get the exact same Cortex XDR error whether I use Admin or Local user.