QSpice Stalls when using Derivative Function with Behavioral Resistors

I encounter issues using the derivative (DDT) function with behavioral resistors. It seems to work totally fine with behavioral sources.

The following works fine :

The error occurs when using the derivative function DDT with the behavioral resistor as below. This causes QSpice to stall when the ‘Run’ button is pressed.

Rather than creating a plot or showing Total Elapsed Time in the Output window, it does not generate the plot and the output is blank :

Also, QSpice does generate the Rawfile…

…but when I try to open it I see this :

The weird thing is that although I mostly encounter the error above sometimes it works. Sometimes if I just wait several minutes and hit the run button again, the plot generates no issue and displays what it should.

I just closed the file and opened it again after reading some other posts for a few minutes. Didn’t change anything, same schematic :

But this time, seemingly for no reason, the plot generated and I got a ‘Total elapsed time’ message in the Output :

Even the value of the output current displayed in the graph makes sense. 1 Volt / 8 Ohms = 125 mA.

Then I try hitting the ‘Run’ button again… and it stalls. Same error as in original post. Inconsistent behavior.

I am running with this version of qspice without seeing problem:

Interesting. Just tried again, version is even higher for me, but still encountering the problem…

QSpice64 works with the ASCII File, but the GUI QUX does not work using the ‘Run’ button.

I used the “View → Netlist” feature to look at the ASCII Netlist that the schematic was generating, then I saved that ASCII Netlist as a separate file.

I ran QSPICE64 on the ASCII Netlist file (SpiceStack2, in the screenshot below) and told it where to output the Rawfile.

And it worked? IDK why, but it seems like I encounter the problem when specifically using the ‘Run’ button in QSpice. When given the ASCII Netlist, QSPICE64 works no problem.

Windows Error Generated When Using Run in QUX

I opened up the Event Viewer in Windows, and discovered that there is an error generated when I try using ‘Run’;

Running with latest version of qspice for your problem, I received no errors: