Qspice Installation Issue

I am unable to install QSPICE. It downloads 5.5KB and disappears.


Hum. Looks like it thinks it got past the http to https handoff but choked on the very first buffer. I think you’re going to have to try a different ISP connection. Perhaps you’re behind a corporate firewall that’s causing trouble.

Hi Mike,

yes, we are behind a corporate firewall.
How to install in this scenario? I will check with my IT team.


Where I can get the full installer download?

I think if InstallQSPICE.exe can’t download it, our OS can’t either. Have your IT department fix the problem.

Yes, I would like the full download also.
The firewall behaves differently in download and install modes.
2 different applications.

The full installer is currently only available via secure, digital signature verified, download via InstallQSPICE.exe. The downloader went through some growing pains in the last week or two, but at this point I simply do not believe there is a problem with it.


What is the version number of the downloader do you see? It’s displayed in the bottom left hand corner.


As mentioned, I cannot get past the download action of the installer.
So I only have the version of this file:

I think your ISP is locally caching the file. When you launch it, you should see the version on the dialog in the lower left hand side, like this:


Or if you launched already As Admin, then like this:


Yes, I cleared all cache for last 7 days and same error.
I do not see a version number in lower left.
Before clicking yes…I see the signature is valid.

If the version isn’t in the lower left hand corner, your machine or ISP cached the file. Your IT dept might be able to help you clear where ever it is cached.

The file is hosted on Amazon Web Services and cached world wide on that distributed platform. I marked the cache was marked stale when I updated it. The delay between marking a file as stale and that propagating world wide is very short with Amazon. So only your IT dept, ISP, or local machine is to blame.


Ok, I will get back to you after trying with another networked PC under my control.

Tada! Works at home.
Yes, there is a firewall and/or antivirus issue at the office.
Though, I had no problem with the LT installer tech.
I will investigate further.

Thanks for your patience.

Hi Mike,

Today I tried again without any network firewall changes. This time magically everything worked :slight_smile:

Still no go at office.
What is the URL of the server so I can whitelist it?

It is not any active block from IT. It is because the download server is too new.
This is a built-in filter from many corporate firewalls.
I asked for a new classification of the servers, GetSpice, MarcusAurelius, and then we’ll see.

Ok, the installer was being blocked by corporate firewalls because of the newness of the URL.
After the reporting agency upgraded the site, the block continued internally and required an override or whitelisting.
All good now.

Good news. Thanks for the update.