QorvoOne not detecting device

I just started to work with QM33120W, and tried to connect it via QorvoOne app.
No matter how long I waited, nothing showed up. I am using Mac(mac OS 14.5)

This is what I have checked.

  1. I installed Qorvo Nearby Interaction using the application on iphone. I could detect
    nRF52840DK(B17180F1) and measure the distance, angle and stuff. So I have confirmed that the board is powered and the firm ware was there and it can transmit and receive signals .The board was powered and I made sure to reset it before connecting to it.

  2. When I checked my usb ports, nothing showed up. I am considering that this is due to not recognizing devices by usb ports on my mac rather than the board problem.

Can someone kindly suggest any help? It will be a great honor for me.

Rieh Yu

Hi @riehyu!

To connect to the Qorvo One app you need the UCI firmware version to be flashed. After flashing, connect your board to your Mac via the User USB (J3 I think), not the J-Link you used to flash (J2).

The application will check the available ports and connect when it finds the board.

Please let me know if it worked.
Kind regards!