Programming PDOA node


I ran into an issue when using the beta PDOA kit. The node no longer works with the desktop software, and i’m wondering what went wrong and what I can do to make the node work with the desktop app again.

The node worked fine out of the box, with the desktop application. I could connect the node to my computer, run the app, and see the location of the tags. Then I attempted to modify the node’s firmware to include diagnostic reports. After that the node was no longer detected by the desktop application. I used j-link to flash the provided hex file but still no change.

Note that the board isn’t bricked. I can debug the example project.

The software i’m referring to was included in the kit. I used the following:
the provided Segger project, located here: BETA_PDOA_KIT_RELEASE_1.0\Software\Sources\dwm1002\examples\dw_pdoa_node

the provided hex file, located here: BETA_PDOA_KIT_RELEASE_1.0\Software\ARM_Hex\dwm1002_node

the provided desktop application, located here: BETA_PDOA_KIT_RELEASE_1.0\Software\PC_GUI

1 Like

Seems strange. Can you do a full erase of the Node before re-programming the Hex?

I just erased the chip and flashed it again. Still no change

Just repeated your steps - downloaded the complete package, updated node’s FW from the package and started PC app - it works.
One possible suggestion - if you plug in the USB cable to node’s lower socket and nothing happens (no blinking LEDs) - press the Reset button(SW2, the top one) - I think the problem is in the USB initialization.

If board is blinking - check the USB Serial device, does it appear in the Device List?

If the tag is also connected to your PC - try to disconnect it, launch the PC app and connect tag again (PC app tries to connect to the tag’s debug port and fails to do it).

1 Like

Did you use J-Flash Lite over USB to program the device? If so, what settings did you use?

Never mind. The issue was the ‘Joined’ checkbox. I didn’t realize I had to check it to see the display.

Yeah, after reprogramming the list of known tags (which node keeps in NVRAM) is erased - you need to join your tag(s) again.

Excuse me, can you explain to me what you had done to reflash the node because I am kind of a newbie in this field. Thank you.