Not getting 10Hz update rate

I noticed that though Decawave says the update rate of the position is 10Hz(0.1 sec) I only occasionally get this update rate. Most of the time the update rate that I get is 0.1Hz (10 sec for one message) and from what I understand this is because the tag/anchor goes to sleep.
If this is the reason, how can I disable this sleep mode so that I can get a steady update rate of 10Hz. If this is some other problem, I’d really appreciate if anyone can guide me on how to fix this.

The tag lowers its update rate when it thinks its not moving, based on accelerometer readings. Assuming you’re using the Android app, you can turn off stationary detection in the tag settings.

Oh great. Is there a way to turn off this stationary detection through UART?

I’m not aware of a way to do it through UART, but there should be a full list of commands in one of the guides. The only way I know of is through the Android app.

The standard software is unfortunately very limited when you want to do anything that isn’t the exact use case it’s designed for. Any additional features will require writing your own code. The code examples are a good starting point but you’ll need someone who knows C and is comfortable writing embedded code (or be willing to do that yourself).

1 Like

The stationary detection can be disabled using API TLV over SPI,UART using call dwm_cfg_tag_set(), or via shell using command “acts”, please, see Firmware API guide.

ot you can increase stationary update rate using call dwm_upd_rate_set() or shell command “aurs”


1 Like

Thanks a lot guys! This was exactly what I was looking for