No unassigned devices found with DWM1001-DEV

Hi, I’ve just acquired 4 DWM1001-DEV boards and I’m trying to use the DRTLS Android Application but when I start the Device Discovery, I can not find any device.
The 4 boards are powered using the USB port of the computer.
My android version is 9 (Samsung galaxy S9).
I tried with other smartphones but I got the same issue.
Furthermore, the only LED ON is D20(On-Board J-Link Active), she stays lit in red.

If anyone knows a solution, please help me,
Thank you,


Hi Hugo,

Are the DEV programmed? The Red LED is for J-Link and that is correct operation.
The other LEDs should be active if the Nordic is programmed with the PANS firmware HEX file.


Hi Ken,

I only plugged it to an USB port, and I would like to use it with the Android Apk.
All the other LEDs are not active, it is the only one (J-Link). How can I fix it ? Do you think that the current could be too low ?
I don’t know how to use the PANS firmware HEX file as you said.

Thank you so much for your answer,


Hi Hugo, I have the same problem. How you fix it ?
Thanks ,

Hi @hugo_gam

Please see document DWM1001 Gateway Quick Deployment Guide. There are all detailed instructions to run a DRTLS System.

Briefly, you must flash the firmware to the boards, configure them through serial terminal, setting up the anchor positions, Network ID, and so on, and finally, access the front end that will be running at Raspberry Pi.

The same Raspberry Pi will serve an MQTT server where you can access all data related to tags and anchors. But believe me, the document has everything in detail. :slight_smile:

But AFAIK, there are some points you must consider:

  • I’m not sure, but I think PANS 2 (the firmware image available on Decawave site) doesn’t work with Android APK.
  • You need at least 6 DWM1001-DEV boards:
    • 1 Initiator
    • 3 Anchors
    • 1 Gateway, to be connected at a Raspberry Pi 3 B. Here a annoying thing to do: you must acquire a 2x13 male header and solder it to the DWM1001-DEV board to connect it on the RBPi (see the photo below).

Let us know about your progress, and feel free to ask if have any further questions.

Ricardo Brandao

1 Like

Hi everyone,
I did it thank you so much @programonauta for your help !
@Mike I fixed it with J-Flash Lite and the PANS firmware HEX file. I flashed my DWM1001 with the .hex and now it is working fine, the other LEDs are blinking and I can use the APK with my smartphone.


1 Like

Thanks for the answer can you explain me how to flash the device .

1 Like

Hi @Mike

See Gateway Quick Deployment Guide, Section 2. There you will find the link to download hex file, and all instructions to flash the firmware using J-Flash Lite software.


Ricardo Brandão

I keap having problem I can not activate the JLINK CDC UART on Windows 10 having problem 'this device can not start (Code 10)" on device manager and so when i start J-flash lite i have “No emulators connected”. I check the driver of the JLINK CDC but W10 say’s it’s up to date.