MQTT broker not showing tag location topics


I have successfully set up the raspberry pi gateway and 4 anchors + 1 tag + 1 gateway to a network, and it shows the tag position via the web manager. My issue is that when i connect with MQTT.fx i only find the uplink/config topics. So one example topic is dwm/node/142a/uplink/config and all other topics are the same but with different node id’s, but i see no uplink/status topics or uplink/location topics. Does anyone have any idea what may be the issue here?

Hi railon,

This is a bit strange, if you see a tag on the webserver then you should see a location topic on mqtt as the webserver connects to mqtt itself to retrieve the data.

So when you are scanning for topics you only see config topics correct ?


Hi Yves,

That is correct! I also tested to manually subscribe to the location topic by entering the topic name and got the position once. I didn’t manage to replicate this though and the topic still didnt show up under the scanned topics even if i recieved the position once.

Best regards,
Sebastian / Railon

Hi Sebastian,

can you see the same issue when using mosquitto_sub as described in this post?



I installed mosquitto but didnt get the second command go go through, i just recieved “Can’t open %H:%M:%S]’: No such file or directory at /usr/bin/ts line 95.” as a response. And doesn’t the second command sort of make the raspberry pi subscribe to itself, or did i miss the point of it?

Here is also a screenshot from MQTT.fx. 1


the errors says your system does not have ‘ts’ command. You can install it e.g.
sudo apt-get install moreutils

‘ts’ is used to print input with timestamps.


I managed to solve the problem and the reason behind it all is quite embarrassing…
Somehow i entered broker port 1883 instead of 1885 and that was the cause behind it all. I noticed it when i tried the connecting from another computer and everything worked.


Maybe you can enlighten me: I also have 4 anchors + 1 tag and RPi + Listener gateway.
When I run MQTT.fx on RPi I enter IP Address of RPi and port 1885 and I get only this topic to subscribe:
TopicsCollectorService: messageArrived: topic: dwm/gateway/b827ebe61adb/uplink

and I have no idea where it is coming from and what that device is (I have no such devices on UWB network). Or maybe the IP address should be that of the Listener (if it exists at all)? (BTW I tried to have the device attached to RPi either Listener or Active but that did not change a thing…
Any ideas?

By some reason I got 2 id’s/topics of the gateway when I check for topics, but it is supposed to be at least one topic for the gateway to show status and settings.

If you use the decawave mobile app or connect to your RPi’s IP address via your web browser, do you see any of your tags, and are they connected to a network?