missing files in DWM1001 source code software package

Within the Firmware user guide (v1.1) there is said to be a simple example SPI API given in the DWM1001 Host API package. However, after downloading this package from the official decawave website (https://www.decawave.com/products/dwm1001-module - a couple of times to make sure) and navigating to the /Source_Code/dwm1001_host_api folder, it is empty.

Is this another case similar to the bluetooth api where it is deemed not ready for public consumption?

Hi Kevin,

[color=#333333][size=small]/Source_Code/dwm1001_host_api folder is actually a rar archive[/size][size=small] and is not empty.[/size][/color]

[color=#333333][size=small]Can you try to download the file again and extract it to make sure there wasn’t an error ?[/size][/color]


I have redownloaded (now v4 rather than the previous v3) and still get the same issue. The folder appears empty when extracted using Archive Manager. When extracting via console:

I unzip the entire folder

$ unzip DWM1001_DWM1001-DEV_MDEK1001_Sources_and_Docs_v4.zip

enter the Source_Code directory and attempt to extract the tar file:

$ tar -xvf dwm1001_host_api.tar tar: This does not look like a tar archive tar: Skipping to next header tar: Exiting with failure status due to previous errors

This extraction process does work on the package beside it (dwm1001_on-board_package_v1p0.tar) in the same folder.

$ tar -xvf dwm1001_on-board_package_v1p0.tar dwm/ dwm/.cproject dwm/.project dwm/.settings/ dwm/.settings/org.eclipse.cdt.core.prefs dwm/dwm_openocd.launch dwm/examples/ dwm/examples/dwm-simple/ dwm/examples/dwm-simple/dwm-simple.c dwm/examples/dwm-simple/Makefile dwm/examples/dwm-simple/README dwm/include/ dwm/include/dwm.h dwm/include/dwm.mak dwm/lib/ dwm/lib/dwm.o dwm/lib/extras.o dwm/lib/libdwm.a dwm/lib/libtarget.a dwm/lib/nrf52_swd.cfg dwm/lib/target_s132_fw2.ld dwm/lib/vectors.o dwm/recovery/ dwm/recovery/bootloader_s132.bin dwm/recovery/dwm-core_fw1.bin dwm/recovery/dwm-core_fw2.bin dwm/recovery/dwm1001-flash.hex dwm/recovery/s132_nrf52_3.0.0_softdevice.hex


Never mind, I didn’t fix the problem but somebody extracted it on their windows computer and sent me the contents.

I tried it on two separate ubuntu computers (14.04 and 16.04) and both experienced the same error.