Mdek1001 serial connection problem

I use MDEK1001 device for my internship project. I cannot connect any tag or anchor with my pc using serial port. I use Ubuntu 20.04 operation system and also try minicom and putty which is serial connection application. I can see this device in PC but cannot connect as an series. Minicom’s scene stay like given code in below, and if i want to write anything it writting as a @ symbol. I cannot see any letter or number or ex…
Welcome to minicom 2.7.1

Compiled on Dec 23 2019, 02:06:26.
Port /dev/ttyACM0, 10:12:56

Press CTRL-A Z for help on special keys


I had the same issue where I can connect to the device, but nothing works. Make sure you are using the correct baud rate, which is 115200.

If you want to run it from the ubutntu terminal you can write

sudo putty -serial {device path} -sercfg 115200,8,n,1,X

I also try this commend for connection with putty but there is no data or something. Only empty screen i can see.

When you run putty/any serial terminal with the correct baud rate, you should press enter twice in order to see what i believe is


And then you can start typing the commands you want to run

I tried all of these but it doesn’t work. It only worked once and shut down immediately and then never worked.

Thats weird. Did you download the PANS firmware on the devices first or did you connect them directly?

I tried to download PANS firmware but not finding any website for download. So consequently i have not PANS firmware. Do you think problem is this? If you can find, please give me link for download PANS firmware.

Yeah that’s probably the issue.
Head to this page DWM1001-DEV - Qorvo where you can find all the information about the boards.

  1. Go to documents

  2. Click DWM1001C Software and Documentation Pack ( to download

  3. When you download the files, head to DWM1001/Product_and_Design_Documents/DWM1001-Firmware-User-Guide.pdf (This pdf is a guide on how to download the software you need to add the firmware to the devices)

  4. The firmware can be found in DWM1001/Factory_Firmware_Image
    You basically use the hex file as instructed in the user guide and you should be set

And if you have an android, you can also download the APK from the first link.

Thanks for your attention firstly. I apply this steps but nothing is change. I tried to upload .hex file using JFlashLite app on tag. I alwayys get an error as
> Conecting to J-Link…
> ERROR: Cannot connect to J-Link.
> Done.

Are you using a virtual machine?

no im using embedded ubuntu 20.04

Are you running it with these exact parameters? The only issues I can think of is that the device is not connected, or you’re not using the correct parameters.

I run with this parameters but as i said it is not running.

Hi @youssef @duygud
I see that the docs it too long to read :sunglasses: . The @ is actually the readable part of an error packet which is returning the binary API interface. If you want to enter into the shell mode you need to hit enter twice (hit it twice fast).