MDEK1001 PC ComPort Tag Positions

I have the MDEK1001 Dev kit up and running just great.
I have a windows computer connected up to one Tag reading it’s position and all 4 Anchor’s positions just fine using the “les” “lec” commands.
When doing this it only gives me the data for the USB connected tag and the 4 anchors.

I have 1 more tag roaming around that the Android app gives me position for but how can I fetch this other tag’s position from the into the PC?

You need to setup one of the units as a listener - tag or anchor set to Passive mode.

So you would have 4 anchors, 2 tags and a listener connected to the PC.

See the ‘MDEK1001 Kit User Manual’ page 18 section 6.4

Ah thanks Kenneth. I missed the part about needing to set it to “passive” to make it the listener. Everything worked so well right out of the gate I just skipped right past that.

Thanks Kenneth. I was able to test out last night and it all worked as expected.

What is the communication between listener and other units ? BT ? UWB ?

Is whole topology work as mesh network to communicate each other ?

If listener connect all units one by one it has e weakest point to cover whole network ( distance could be a problem )

OK saw this and read the section… Made a device a listener (passive)… Connected to USB, com15… Using hyperterm connected at 115200 8N1…

All I get is @@@@@@@@@@@@@@ when I type in keys.

Suggestions? Firmware update required? everything else works great!

Ignore… I somehow managed to bang on the keyboard or do something and now it works… Hmmmm…

Type Enter twice quickly, this usually reset the program so you can then type LES to get data.


I followed all the steps and when I enter the les command on the listener, I get this :
[000044.790 INF] loc_data:
10) 18DD[nan,nan,nan,0,x01]

why isn’t it reading my tag’s position ?

Hi @ghadad ,

This happens when the Tag could not calculate the position. The reasons why it happens are

  • The Tag obtained less then 3 distance measurements → connect to the Tag and check using the ‘les’ command if that’s the case. Ensure at least 3 Anchors are running and in range with the Tag.
  • The Anchor’s positions are not set or are too inaccurate → set or improve the position settings.
  • The geometry of Anchor’s placement is not good enough. See Dilution of precision (navigation) - Wikipedia. Try to create a grid like shape where the Tag would be inside the covered area.
  • The distances are too affected by the multipath. You might consider implementing your own Location Engine if your use case allows to improve the position estimation by filtering out or introducing other parameters.

BTW Double Enter does not reset the program but it switches from the UART TLV binary API mode to UART Shell mode. To switch back run the ‘quit’ command in the Shell mode.


I have the same problem.
1 anchor, 1 Tag, 1 Passive connecter to the PC
In Teraterm I receive only @
did you find a solution?

Hi @trizioPucci,

By default the module is in the binary UART TLV mode. Press double Enter to switch to UART Shell mode.


The listener is part of the “IEEE 802.15.4-2011 UWB” netwrork, which is a mesh network. It works even with all Mdoles having BT disabled.
Now as a listener only, I don’t know if it has any disadvantage if the other nodes are not aware of it, what you could do is make a custom listener and test the range and rx quality.

Thanks leapslabs but, as I discovered, the problem was related to the Teraterm [EndOfLine] default sequence.
It must be CR [0x0D]. In my setting I have CR+LF that means [0x0D+0X0A] so double return correspond to [0x0D.0x0A,0x0D,0x0A] and not the expected [0x0D,0x0D].
Setting the default to CR let teraterm work correctly with the double enter.