Latest 2/20/2024 Version Crash

I was running .tran simulations all day (2/20), just this evening Qspice updated to the latest and now it will crash when i try an run. The program itself doesn’t crash but the waveform viewer fails to launch automatically. If i open the waveform viewer manually, then run, it will crash.


Issue seems to resolved itself, I’m not sure why, I didn’t do anything different.

Edit 2/21
New day and the Waveform viewer does not open, i tried a could different circuits and they all do it, seems like a real bug.

1 Like

I have the same. Sometimes it helps if I close/restart QSpice, sometimes I need to reboot my PC. Then I can do some runs again.
If I could make steps to reliably reproduce the issue, I could send Mike an email. But so far to me it appears to be random…

I find the viewer to crash, when after a a sim-run, you do some edits in the circuit,
it tries to plot every node you touch during edit, and then it crashes.
Closing the viewer and restart helps.
Qspice simulator itself does not crash

Similar to your experience… simulation run but halt, have to close/restart Qspice. Before today update I cannot recall I encountered that. But cannot find a way to replicate that.

indeed, earlier versions did not have this…

kind of good to hear I’m not the only one, i was worried it was my machine.
and like you said, it does appear to be random

Latest update solved the issue for me. :grinning: