Kernel Panic on Raspberry 3


I’m trying to setup described on document DWM1001 Gateway Quick Deployment Guide.

I succeeded configure all DWM1001-DEV Boards, but I have problems with Raspberry Pi.

Followed all instructions on item 4.2 SETUP THE RASPBERRY PI 3 MODEL B.

Flash a SD Card with image file DRTLS_raspbian_R2.0.img:

07/02/2019  06:00     5.242.880.000 DRTLS_raspbian_R2.0.img

But when it try to boot I get the message:

---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)

I’ve tested the same SD card with a Image downloaded from Raspberry site and worked fine.

I appreciate any help.



Hi Programaunota,

It may not be relate but double checking what is your SD card size? I think the image we provided is only formated for 16gb and 32gb SD cards.


Thanks @Yves_Bernard,

Yes I’m trying to format it on a 8GB SD Card. I’ll try another one with 16GB or 32GB and I’ll post the result here.

I am experiencing the same problem, I just recently tested with a 16 gb SD card but got the same kernel panic error. @programonauta, please let me know if you succeed with a 32 gb SD card.

Thanks in advance for exploring this problem.

Thanks for share your experience @EmilHau.

I’m leaving now to buy the SD Card. With this information I’ll buy a 32 GB SD Card too. So, I’ll try two possibilities.

As soon as I got the results I’ll post here.


I did not get a kernel panic after buying a 32 GB SD card. However, the 16 gb SD card I used might have been broken (even though I successfully manage to run Raspbian Lite on it) :slight_smile:

1 Like

@EmilHau and @Yves_Bernard

I’ve just tried with a 16GB SD Card and Raspberry worked fine.

Next step, test all system with anchors, init and tags. Looking forward to see tags “walking” on my screen :slight_smile:

Thanks so much guys!

1 Like

This would be the kind of thing that would be useful to put into the documentation. I spent a long time trying to figure out why all of my 8GB cards didn’t work.


Hi all, I tried in two 16GB sdcard’s and both kernel panic. With another raspbian image (for example Raspbian Stretch Lite) boot without problems.

Downloaded twice the DRTLS_Raspbian, also. Both with kernel panic.

Any clue?
Or, can you create the image to a lower size SD card?

Hi @ramg,

I bought two Class 10 SD Cards (one 16GB and another 32GB), both worked fine.

My question could be no sense, but did you try a 32GB SD?

Another question…

What model of RB3 are you using? It only works with model B. RB 3+ is not supported.

Hi programonauta, the model is RB 3B and didn’t try with 32GB, maybe I will today.

The image has two partitions. The boot one with no problems, and the Linux one. I cannot mount the Linux partition, in a Linux distro using:

mount -o loop,offset=50331648 ./DRTLS_raspbian_R2.0.img /mnt/raspbian/


 wrong fs type, bad option, bad superblock on /dev/loop0,
       missing codepage or helper program, or other error

I think the problem is on the image file.
Downloaded from

zip file including documentation and image files.
The SD card size in above procedure has no connection.

dmesg’s output:

EXT4-fs (loop0): bad geometry: block count 3788800 exceeds size of device (1267712 blocks)

Hi @ramg

Unfortunately, I’m not an expert in Linux mounting system.

@EmilHau experienced the same problem with 16GB SD Card. Let’s hope you get with a 32 GB.

Tried with 32GB SD card, and boot correctly.
I think the problem is the .img is genererated for 16GB SD card, but normally (not always) the 16GB card, has 14.7GB real capacity, so, the image is larger.

I’ll try some combinations maybe to generate a .img file considering 14GB sized cards.

1 Like

Here are the steps we took to shrink the image to fit our card (linux):

LOOP_DEV=$(sudo losetup -f)
truncate -s +12G ${IMAGE_NAME}
sudo losetup ${LOOP_DEV} ${IMAGE_NAME}
sudo partprobe ${LOOP_DEV}
sudo gparted ${LOOP_DEV}

shrink rootfs in gparted partition to fit your card

sudo losetup -d ${LOOP_DEV}
truncate -s 5242880000 ${IMAGE_NAME}