Infineon MOSFET model not running in QSpice but in LTSpice


I am having problems with a MOSFET model from Infineon.
Even a very simple circuit is not able to run in QSpice (time step too small).
No matter what I try, it just won’t work…

On the other hand I tried the same circuit in LTSpice and it runs without issues.
I don’t even have to add things like .opt cshunt=10p or use other solver options.

Is LTSpice better in handling those complex SPICE models?

Is there a way to get the Infineon model running in QSpice?

Infineon_AIMBG120R080_test.qsch (13.9 KB)

Best regards,

Hi Markus,

It might be too late, but I hope this helps.

I tried your simulation file and got the same result. I couldn’t get any results except for a “time step too small” error in QSPICE.

However, you can use Infineon’s similar device, for example, IMBG120R090M1H. It works well in QSPICE!
(But for this simulation, LTSPICE runs much faster than QSPICE.)

NMOS_Power_Tc_Ta_with_SS.qsym (1.1 KB)
test_IMBG120R090M1H_tran.qsch (7.2 KB)


Please turn off the “Fast Math” setting from the Edit → Preference menu. It works fine.
If you’re still having trouble, please update QSPICE.
I’m not sure whether it was this setting change or the QSPICE update that fixed the issue.

test_AIMBG120R080M1_tran.qsch (762.7 KB)