How to get locations of the tags in bridge raspberry pi


I have 4 anchors and 1 tag. All of them are working fine on the android app and is showing the location of tag. They are showing FW2 as operating firmware.

I also have setup one anchor as bridge mode using nis and nmb commands. I have mounted it on top of raspberry pi. I can access it using UART in pi. When I run si command to get the system information I can see its a bridge node by looking at the following line:

[000018.580 INF] opt: AN [color=#ffcc33]BRIDGE[/color] LEDS BPC UWB0 I2C SPI UART

But when I run command “la” to get the list of anchors it doesn’t show any anchors while all of them are with same network id.

[color=#333333]dwm> la
[color=#333333][000008.900 INF] AN: cnt=0 seq=xFF[/color]
[color=#333333][000008.900 INF][/color]

I think the location engine in the tag is enabled as I can see it in tag info in the Android app but didn’t found any option to check location engine for anchors.

How can I resolve this issue? How can I get the list of connected tags/anchors and then get the location of tags in Raspberry pi.?


1 Like

I would like to have help on that too.


Hi guys,

This is not supported yet in the current version.

We’ll provide a new release in the coming weeks that will enable to bridge node and use of nmb command.

For now, please setup the node as passive, and use the command lep or les to get coordinates of surrounding devices.