High consumption on tag in low power mode and anchor with different panid

Hi there, i have a problem with my tag in low power mode.

Im measuring consumption and everything works fine but when i have an anchor with different panid in the neighborhood the tag gets a high power consumption with recurent peaks of about 126 mA with a duration of 2/7 of the time aprox. Is this a normal thing ??? because it’s ruining my low power consumption solution that im working on.

Another thing is that when i have another anchor with the same panid of the tag everything goes back to normal and i dont get those weird current peaks. im leaving a picture of the measurement i made with a resistance of about 2 ohms so the milivolts that are shown in the osciloscope are two times the real consumption.

i leave the tag configuration here too:
sys: fw2 fw_ver=x01030001 cfg_ver=x00010700
[000028.840 INF] uwb0: panid=x0010 addr=xDECA87E2F624CE39
[000028.850 INF] mode: tn (act,twr,lp,nole)
[000028.850 INF] uwbmac: connected
[000028.850 INF] uwbmac: bh disconnected
[000028.860 INF] cfg: sync=0 fwup=0 ble=1 leds=1 le=0 lp=1 stat_det=0 mode=0 upd_rate_norm=5 upd_rate_stat=5 label=DWCE39


Hi, excuse my English, I am not a native of the language.
I had a similar problem, I solved it by compiling the firmware by commenting on the dwm_shell_compile (). Apparently this runs a thread that prevents the device from entering low power mode.

I hope my experience will serve you.

hi thanks for the reply Fdiazz , I have tried commenting the dwm_shell_compile line and that wierd consumption is still there.
Please if anyone has another suggestion or answer to this i would appreciate it.

I share a fragment of the code I use.

are you using the DWM1001-DEV board? If so, be sure to remove the jumpers corresponding to the j-link. sometimes the nrf can enter debug mode and cause unwanted consumption.
I also see that you have activated lesd, I suggest deactiver and test.


void dwm_user_start(void) {
uint8_t hndl;
int rv;
//Disabling ble by default as softdevice prevents debugging with breakpoints (due to priority)
/* Create thread */
rv = dwm_thread_create(THREAD_APP_PRIO, app_thread_entry, (void )NULL,
“app”, THREAD_APP_STACK_SIZE, &hndl);
//configure as tag
dwm_cfg_tag_t cfg;
cfg.stnry_en = 1;
cfg.meas_mode = DWM_MEAS_MODE_TWR;
cfg.low_power_en = 1;
cfg.loc_engine_en = 1;
cfg.common.enc_en = 0;
cfg.common.led_en = 0;
cfg.common.ble_en = 0;
cfg.common.fw_update_en = 0;
cfg.common.uwb_mode = DWM_UWB_MODE_ACTIVE;
rv = dwm_cfg_tag_set(&cfg);
// config rate
rv=dwm_upd_rate_set(250, 600); // update rate 25 second. 60 seconds stationary
Start the thread */

Hi Juan,

sorry for responding a bit late. It it took me a while to understand your issue.

If I understand correctly, then the power consumption is correct when there is no network at all in range of the Tag. When there is some Anchor of the neighbor network then the consumption would increase and you would see the power profile as on the attached picture. Is my understanding correct?

If so then it is a correct behavior. When there is no network at all, the Tag will try to seek for some active network. If there is some neighbor Anchor available, it will try to seek for some Anchor from its network by listening in all Beacon slots. It will do so for a couple of times and if it failed, it will then switch back to the deep sleep and wait for the next attempt.

PS: I don’t think the issue is related with what Felix has observed.