Fatal error - linking .dll


I have troble running simulations with blocks containing C++ code. I tried also to run simulations using th Example files, but i got the same error you can see in the attached image.


Perhaps the file is missing or not set as executable. See if the file is in C:\Program Files\QSPICE\Examples. If not, then maybe your antivirus software deleted it. Since QSPICE is new 3rd party virus companies don’t yet know about QSPICE and that it is virus free.

Hi sanfep

Can you open the Verilog source code “counter.v” from the schematic window?
You can compile it to create the DLL needed for simulation as follows.
From the “VerilogCounter” schematic, right-click on “X1” and select the “Verilog interface” menu.
Then, select “Open Verilog Source” to view the Verilog source code.
Right-click on the source code window and select “Compile Verilog to C++.”



After doing what you suggested, I got this error.

I checked the path C:\Program Files\QSPICE\Examples and this is the result:

If i open the C++ interface and try to compile DLL, i get this error:

I set the example folder to “read-only”, and I got the same error as you showed.
It seems that the Verilog compiler is unable to write to your example folder.

You should be able to run those examples. But if you want ot recompile, you have to copy them to a directory where you have write permission. Please note this comment at the top of counter.v:

// NOTE: If you want to compile this file, you’ll need to first copy
// the files VerilogCounter.qsch, counter.v, and counter.cpp to a
// directory where you have write permission.


@EL34 @Engelhardt
Thank you for your comments.
Unfortunately, copying the files in another directory with write access is not working.
I also tried to create a simple schematic and it wasn’t working.

A new information for you could be that i have checked for new QSPICE updates and the application has been reinstalled. After the installation my simple schematic simulation (as from the following image) was working, as well as the Examples (even if i use the ones that are still inside the non-writeable folder).

However, if i close the application and restart it, i get the errors as in my first message in this thread (even if the content of the folder are exactly the same).

Well, I’m at a loss. At first I was thinking that if you’re using a corporate PC, it might be that new file creation is setup to not be executable. But since you can compile an run, that shouldn’t be it. The recent updates would not impact what you’re doing.

If you are on a corporate PC, I think all you can do is ask your IT group why it isn’t working. I don’t think it has anything to do with what I can control. My basic test vector is that if you go to a store, buy a PC, install QSPICE, it will all work.