Failed to build bin file in CoIDE

I need to build bin file in CoIDE/Coocox to upload it to TREK1000, but after build there is this error:
C:\program files (x86)\gnu tools arm embedded\arm-none-eabi\lib\armv7-m does not exist.
Did any of you guys come across this issue?
I don’t know if this is a problem with toolchain or IDE,I’m not used to using CoIDE.
I’m using CoIDE 1.7.8 and the latest update of GNU toolchain. I also tried Sourcery CodeBench, but same error appeared.
I selected the toolchain path in Coocox correctly.
Maybe you can recomend me some other IDE than CoIDE with which migration of the project will be easy enough for beginner in programming?
Thanks in advance,

Hi Grzegorz

It sounds like your installation of the GNU toolchain might be incompatible with the project. What version of gcc-arm-embedded are you using?

Section 6.2.1: “Using Coocox IDE”, mentions GCC 4.8. I believe this project is typically used with GCC 5.4.

Note that we now primarily support the System Workbench for STM32 IDE. The CoIDE/Coocox is only supported as legacy project. The examples for System Workbench should work with the latest version of the IDE.

Hi seppe,
Thanks for the quick answer.
I just tried 5.4 and 4.8 version and it still give me the same error. Before, I used 9 version.
I use your software, but its lightly changed by my former coworker to work with our external hardware, so I can’t use your example for SW. I know it was working earlier, and that he was using Coocox to create bin file. I just lost the bin file because of this former coworker mistake :(. But I have the right .coproj project.
Would it be hard for me to migrate this project from Coocox to SW? I never than something like this before

I managed to create bin file in Coocox. When I download project again from repository on github, it was giving me another error when i was trying to builed, something about “string index out of range -1”. But I find solution online, I needed to get rid of any “rom” string in linker .ld file. There was one “from” in comment, and when I replaced it with “fr_om” it builded. Weird.
But issue solved