ETK1000 poor range of ~10m with default settings

Hi all. I’m looking for a bit of help troubleshooting the range of my ETK1000. I powered the modules on for the first time today and I’m only getting a range of roughly 10m. Here’s some details on my setup:

  • Default jumper and switch settings and configurations as provided by Decawave (nothing changed)
  • “3.05” label on both modules, PCB version 2.2
  • Mode set to 3 (channel 2, 110 kbps, 64 PRF, 1024 preamble, preamble code 9, non-standard SFD) - mode is optimized for range
  • Modules are powered by inexpensive 2000 mAh USB power banks -> tested to provide up to 1.5 A before current-limiting (0.5 A @ 5 V, 1 A @ 4.8 V, 1.5 A @ 3.8 V)
  • Connected using inexpensive micro USB cables (used in the tests above)

Here’s my test methodology:

  • Placed anchor on 1) indoor wooden floor with antenna facing up, 2) indoor wooden floor with antenna facing sideways, 3) inside concrete floor with antenna facing up, 4) elevated in outside bush (1 m off ground)
  • Held tag with antenna in same direction as the anchor
  • While holding tag, walked away from anchor until tag reading stopped updating


  • Reading stops updated between 9.5m and 11.5m
  • Antenna position didn’t seem to affect range
  • Floor material and elevation from floor didn’t seem to affect range
  • Modules never reset or brown-out in any of my tests

I’d appreciate any suggestions.

Bumping this to the top

Bumping this to the top


1st, when you say “Reading stops updated between 9.5m and 11.5m” Do you mean that one of the boards just stops , eg powers down

Range in a LOS environment eg a big enough field will give you well over 150m , with the default setting. This we actually have tested ourselves.
This would be outdoor. Indoor the range might be different.

I don’t think the battery or USB is the problem, but to be sure , maybe have at least 1 connected to (at least 1) laptop and maybe use another laptop for the other board.
Or have 1 EVB static and powered by a 220-240v 5V USB charger (instead of battery) and the other EVB connected to a laptop.
Then on the laptop start PC DecaRanging and start Main Window Display and Controls (see section 3.2 in the DecaRanging User manaual). Then start the walk ,and if it stops at 10m. just keep walking for another 10 to see if the ranging has picked up again.
Ideally, please place the static EVB on a height (eg 1m) and 30-50 cm from a wall to avoid or minimise the chances of Fresnel holes created or fading because of bouncing signals (see APS006 section 3.4.2 Multipath due to ground-bounce)

Also , could you make sure the antennae are tightly screwed on the EVBs.

And finally , could you say something about the environment?

Hopefully some hints,


Hi Leo. Thanks for the suggestions. I’ll give this a try tomorrow and report my findings.

Ok, so I installed VCP_V1.5.0_Setup_W8_x64_64bits.exe to enable the virtual COM port and copied the settings from page 11 and 12 of DecaRanging user guide (I guessed at the baud rate as I couldn’t find the proper setting in the manual). Note that I’m on Windows 10, but there’s no driver for it, so I’m using the Windows 8 version. Seemed to install just fine. When I try to launch DecaRanging_Cust_MP_v3p05.exe, I get an error message indicating that the software cannot connect to the hardware. See attached screenshots.

I also tried ranging with the setup as suggested. Antennas are tight. I powered the anchor with a high quality 2 A USB adapter and then I powered the tag using my laptop via USB. I get the same maximum range as before. Lost signal at around 10 m. I walked another 20-30 m. Connection did not re-establish.

Interesting find: I tried re-powering the tag when it was out of range. It would not re-connect with the anchor, even when back in range. I had to power-cycle the anchor to get it communicating again. Maybe a bug? Or intended?

Anything else I could try? I’ll be getting my higher quality USB cables in the next week or so to see if they make a difference.

VCP_V1.5.0_Setup_W8_x86_32bits.exe or VCP_V1.5.0_Setup_W8_x64_64bits.exe has been tested to work fine with W8 , but also W10.
Sometimes it’s forgotten by customers to install also the device package dpinst_x86.exe (32-bits OS version) or dpinst_amd64.exe.
See readme file as part of the VCP download. This could explain your error.
Also, make sure your EVK1000 boards are set to USB 2 SPI mode. This is done by setting S1-3 to “OFF” (see table 11 in EVK user manual)

Your 10m with 2x EVK1000 is a mystery. Have you tried outside, or could you say something about the environment.
Once you have Decaranging to work would also be a help.


Thanks Leo. I was able to successfully connect an EVB1000 to the PC software and perform ranging (one EVB acts as the tag in standalone operation, and the other EVB acts as the anchor connected to the PC software). I’ll be playing around with the setting a lot more in the next couple of days.

Small update on the range. I tried my high-quality low-gauge USB cables (2 A capacity charging cables) to see if I could improve the range. Tried with the earlier USB battery banks as well as 2 A USB chargers attached to long mains extensions cords. Spent a good 30 mins walking around to see what range I could get. The somewhat reliable maximum observed is around 13 m. This was tested in an open-air outdoor environment. Same methodology as my first post. Both the battery pack and mains USB chargers produced around the same range.

I’m going to try different device settings to see if I can improve the range. Will post back my results in the next few days.