Eclipse IDE C-code


I’ve been working with the VM, Eclipse IDE, and the simple c-code example for the last three days, but I’ve been absolutely unable to make any progress with it whatsoever.

I’m not sure what I’m doing wrong. I’ve tried several times now to import the example code onto Eclipse IDE, ensuring I’m following the guide exactly, tried to debug it many, many times, ensuring that I’m following the guide exactly, but nothing has happened yet. I’ve gotten the example code to work exactly once, and I have no idea what I did differently that one time.

It seems to be downloading onto the device just fine, but nothing is actually happening. It’s not printing any distance measurements. The Red, green and blue LED’s are all flashing quickly, and according to the dwm1001-dev datasheet that means ‘Bootloader active’, but I’m not 100% sure what that means either.

Can anyone help me at all? This is getting tremendously frustrating.

Could you be more specific . What sample code is it your trying?

I am following the instructions from the Firmware guide:

and using the dowloadable code from decawave’s website.


Have you tried to reflash (with J-FlashLite) the board with the R1 HEX file provided in the download (DWM1001, DW10001-DEV and MDEK1001 Documents, Source Code, Android Application & Firmware Image)?

I wonder if there is a Firmware update happening, maybe turn off the other Anchors.


I have flashed the device with Eclipse IDE, using the 3rd build option.

I’m not sure why, but I haven’t been able to get J-FlashLite to work on the VM (It just doesn’t open).

I was able to get the code to download on the Module again since I made this post. I think I may have found my error? I’m now going through the debug options every time I try to debug instead of setting it up just once.

I will try to ensure all anchors are off when coding the device in the future, though, and see if it helps.