DWS1000 and Nucleo F429ZI


I got two new DWS1000 boards and two new Nucleo F429ZI boards, programmed the Nucleo boards with ex_ex_06a_ss_twr_init and ex_ex_06b_ss_twr_resp, but the only response I can seem to get from the 06a board is when I press the Nucleo reset button is the following on COM3:



And for the 06b board, when I press the reset button I get on COM5:


But I’m not getting any other response from the boards (just 30cm away from each other). It’s probably something very minor I’m missing but any ideas what it might be? – I’m guessing others will run into the same issue (I also tried with the 05a and 05b examples and got the same type of response). The DWS1000 and Nucleo jumpers are in their default positions.


Hi Dave

This sounds a lot like a problem we already fixed, but checking the website it looks like the fixed version did not end up on our website yet.

I created a share on Google Drive of the uploaded version. Can you check if this version fixes your issue?

Alternatively, in stm32f4xx_hal_msp.c

you can change

GPIO_InitStruct.Pin = GPIO_PIN_5|GPIO_PIN_6;



and remove

GPIO_InitStruct.Pin = GPIO_PIN_5;
GPIO_InitStruct.Mode = GPIO_MODE_AF_PP;
GPIO_InitStruct.Pull = GPIO_NOPULL;
GPIO_InitStruct.Alternate = GPIO_AF5_SPI1;
HAL_GPIO_Init(GPIOB, &GPIO_InitStruct);

Note that this will be overwritten if you regenerate the project in CubeMX, the fixed firmware package also fixes the CubeMX project.

I’ll check why this fix has not ended up on the website yet and solve it ASAP.

For reference, the problem is that at Decawave we tend to change a solder jumper on the Nucleo F429ZI boards that allows to use SPI1 at the same time as ethernet. If this modification is not done, SPI1 does not work properly and as a result the DW1000 driver fails to initialize.

Hi Seppe,
Yes that fixed it - both 05 and 06 examples are working for me now - e.g. the 05 sends out a the distance every ~ 1sec:

DIST: 0.62 me[uDIST: 0.59 me[uDIST: 0.55 me[uDIST: 0.54 me[uDIST: 0.63 me[uDIST: 0.62 me[u

Appreciate your response,

Good Morning Dave,
Di you just upload those files into the existing src folder. I’m having difficulty getting the boards programmed to range together.