DWM3001C serial

Hi, I am using DWM3001C ( Not CDK ), with j link.

I successfully uploaded firmware via j link through USB. ( used SWDIO, SWCLK, GND, VCC pin )
I had to put power to the DWM3001C chip with DC POWER SUPPLY since power through j link is pretty weak.

But I couldn’t find device through

ls /dev/tty*

  • So, my question is, how can I connect to connect nrf52833 for serial monitor?
    I guess USB_N, USB_P pin is needed, is it correct? and then how?

Thank You!

p.s. I use CLI firmware to set mode.

Hi Hank,
Can you elaborate on how you are trying to connect to the module?
Have you already mounted the DWM3001C onto a PCB?

not yet, I m just soldering…

want to check first

and then make compatible board…
is it this how i connect 3001c with pc?

how to connect to pc?

what is VUSB pin? (no.18)

I would not recommend to test in this way.
If you want to evaluate or test the performance of DWM3001C module, it is better to use it with DWM3001CDK board, which has all the necessary communications and power connections to get started.

Link to Qorvo Website: DWM3001CDK - Qorvo

Once you are happy with the performance of the module, you can use the schematics provided to design your own PCB to meet your specific needs and form factor.

You can check the datasheet for the DWM3001CDK, there you will see the connections needed to make it work.

Ok, I tried to try with DWM3001CDK, I uploaded successfully through J-link.
following example : https://infocenter.nordicsemi.com/topic/sdk_nrf5_v17.1.0/examples_hw_peripheral_devices.html?cp=9_1_4_6

but after I connected it with even USB(J20 - nRF52833), not through uart tx/rx pin (my final goal),
I couldn’t find the any port opened.

any suggestion?

Have you tried with the Qorvo software?

Click on the link I provided above, and go to documents section and download the SW there.

yes, that is where I got example.
→ DWM3001CDK DK Software, Sources, Tools and Developer Guide/DWM3001CDK DK/DWM3001CDK_SDK/Sources/DWM3001CDK-DW3_QM33_SDK-FreeRTOS_0_1_1/DWM3001CDK-DW3_QM33_SDK-FreeRTOS/SDK_BSP/Nordic/NORDIC_SDK_17_1_0/examples/peripheral/uart/pca10100/blank/ses

I guess it depends on firmware, tty setting got recognized or not.

Have you tried uart example?