DWM3000 - Is OTP required for working operation?

I designed my own board of a DWM3000 working together with an ESP32-S3 MCU. I can communicate with the board but the simple rx/tx example gets stuck while waiting for the send/receive confirmation flag. I can read out temperature and voltage raw values, so communication with the board is stable…

I ordered the DWM3000TR13 from mouser so their OTP memory is clean, no EUI nor voltage or temperature calibration is programmed.
The status register looks like this and constantly shows some states, even after resetting the flags:00000001100000000000000000000011

The event counters remain at zero, event counting is enabled:
ARFE: 0, CRCB: 0, CRCE: 0, CRCG: 0, HPW: 0, OVER: 0, PHE: 0, PREJ: 0, PTO: 0, RSL: 0, RTO: 0, SFDTO: 0, TXF: 0

Might the missing OTP programming be the problem? Or should sending and receiving work without. Any other ideas what might cause the issue?

I’ve used DWM3000 modules with factory default OTP memory so it’s not an issue.
What code are you using to drive the modules and are they getting initialised correctly? Can you read the device ID register correctly when the SPI bus is running at high speed?

I tried different libraries, but I worked mostly with this one: GitHub - Makerfabs/Makerfabs-ESP32-UWB-DW3000
Initialising works and I also get “deca0302” when reading the device id, also with high speed SPI. I also get a PLL lock and confirmation that initialisation was successful. But then I never receive a message. I’m starting to suspect the ESP32-S3 since some people reported SPI communication issues with this chip. Makerfabs has a device working with ESP32 (no -S3) with the same library…