I’ve made a custom PCB very similar to the DWM1004c with stm32l041g6u6str using available TWR firmware package. I flashed it with no problem using ST-Link Utility and the ST-Link V2 USB. After that, I connected to the UART Tx and UART Rx pins of the STM32 (PB7 and PB6) with an FT232H Board (D0 and D1) and tried serial communication in PUTTY (baud rate 38400). There was some response. I couldn’t send the shell commands (INIT, STAT, etc.) or read data. Only able to make it say INIT FAILED. This implies UART is working, but that something in DW1000 initialization is causing an error. What would be reasons in the firmware to cause this error to appear? Does this occur if using 3.3V for all powering of the DW1000 instead of the 1.8V on the two pins? Or does this simply mean it is not able to read the device name? Or do I need to switch my flashing/data reading process?
Hopefully there is a simple fix, but any solutions are welcome. Thank you!

Update: It worked! The only change I made was in soldering: I learned that when soldering your own circuit with microcomponents, if you leave too much flux behind it can disrupt the connections. Thoroughly cleaning away flux with IPA did the trick.