DWM1004C PHE (Physical Header Error)

Hello everyone,

I’m currently developping on a custom board with a DWM1004C, where I program the STM32 inside of the module.

My goal is to work in TDoA with an already existing (and working) system.
Currently my device is not detected by this system so I took some step back.

I programmed one tag with a “simple Tx” example codes (I use the code from the TDoA for the initialisation of the periphericals and use the Simple Rx for the “while(1)” loop) and an other one with simple Rx on debug with STM32 Cube IDE (I have a ST-Link V2 mini).

I manage to detect preamble, when the Tx device is on (and nothing when it’s off, which is conforting) but I have manly PHE error (other error is Solomon Reed but less frequent).
The status is 0x801302 (or 0x81ab02 but less frequent).

I tried to put a delay after the “dwt_rxenable(DWT_START_RX_IMMEDIATE);” (which solved the issue for someone on this forum) and also to put the device under an external power source but it didn’t work.

this i my configuration
static dwt_config_t config = {
5, /* Channel number. /
DWT_PRF_64M, /
Pulse repetition frequency. /
DWT_PLEN_1024, /
Preamble length. Used in TX only. /
DWT_PAC32, /
Preamble acquisition chunk size. Used in RX only. /
9, /
TX preamble code. Used in TX only. /
9, /
RX preamble code. Used in RX only. /
1, /
0 to use standard SFD, 1 to use non-standard SFD. /
DWT_BR_110K, /
Data rate. /
PHY header mode. /
(1025 + 64 - 32) /
SFD timeout (preamble length + 1 + SFD length - PAC size). Used in RX only. */

I hope it’s not too confuse and that someone will be able to help me.

Thanks in avance,