DWM1001 PANS Release 2

Hi Tearus,

The gateway mode is not really non-ble. You an use BLE but in this case it is not possible to enable AES encryption of UWB packets. If you whish to encrypt the packet, then the BLE is not available.

EDIT: If your question was referring to the actual gateway itself, then I want to clarify that yes, BLE cannot be enabled on the gateway. You can still use BLE on anchors/tags which belong to a network with gateway.

The power calculator is currently not updated , but R2 tag consumption will be similar. Please note anchors and gateway are meant to be powered by the main.

EDIT: To be a bit more specific, the tag power consumption will actually be better with this new release but we haven’t quite quantify by how much yet.

Regarding the system capacity, please refer to the system overview enad performance guide, it is widely covered. Adding a gateway does not reduce the system capacity. You just need to make sure that the device you want to track are within UWB range with the gateway.


still u haven’t answer my question if i was to change the firmware on the units to R2 can i go back to release 1 like described in the first version of the documents for the MDEK1001 kit .

We do not recommend users to develop product with the R1 as it contains a umber of uncorrected bugs.

But yes, if you still have the R1 binary file nothing prevent you from re-flashing your R2 devices with R1.


Thanks a lot for the release.


The Decawave Positioning and Networking Stack (“PANS”), available as a library accompanied by source code that allows a level of user customisation. The PANS software is pre-installed and runs on the Module as supplied, and enables mobile “tags”, fixed “anchors” and “gateways” that together deliver the DWM1001 Two-Way-Ranging Real Time Location System (“DRTLS”) Network.

But I can’t fing the PANS’s source code

You have somewhat answered your own question.
PANS is shipped as a library/binary only. There is no source code for this library available for download.

There is a Segger Embedded Studio project provided that includes this library and allows customers to make a bespoke application on top of the PANS.

thanks a lot!
I’m waiting for long time!

Is there a plan to open pans’s source code.

Hi Killeder,

It is currently not planned to open the PANS core library for DWM1001/C.

Thank you,

Other than the addition of the IoT/Gateway functions, what changes were made in Release 2? Is there a change log?

If I do not use IoT data or Gateway functions, is there any benefit to updating to Release 2?

1 Like

Hi cwallace,

Yes there are many benefits. We don’t have a detailed change log but the main advantages other than the gateway:

  • 30 anchors seat in the super-frame, greatly improving scalability
  • network co-existence
  • AES encryption of UWB packets
  • Compliant with regulation rules (this is not true with R1)
  • Fixing multiple software bugs.

I would strongly recommend any user to use R2 regardless of their requirement of the gateway feature.

Thank you,

Has anyone tried to build dwm-simple under ubuntu with the new PANS v2 build process?
I get this error in the build log:

Building ‘dwm-simple’ from solution ‘dwm-simple’ in configuration ‘dwm1001_configuration’
1> Compiling ‘dwm-simple.c’
1> dwm-simple.c:115:19: warning: unused variable ‘pos’ [-Wunused-variable]
1> dwm_pos_t pos;
1> ^~~
1> Linking ‘dwm-simple_fw2.elf’
1> arm-none-eabi-gcc: error: /home/bm/DWM1001_DWM1001-DEV_MDEK1001_Sources_and_Docs_v9/DWM1001/Source_Code/DWM1001_on_board_package/DWM1001_on_board_package_R2.0/dwm/examples/dwm-simple/output/compiler/*.o: No such file or directory
Build failed

There is a dwm-simple.o in that folder which is odd. But what is more suspicious is that the bundle came with a capitalized “Output” folder rather than “output”… seems like the kind of thing that would work under windows but not linux :frowning:
I’ve tried renaming Output to output but get the same error. Looking at the old eclipse process didnt give me any insights as it seems quite different than the new segger ide.
Thanks for any help

1 Like

Hello kenneth,

Im not able discover(DRTLS manager app) the DWM1001 module after flashing “DWM1001_PANS_R2.0.hex”.

Am I missing any configuration ? I have tested with 3 different mobile phones. Same errorerr

The error in the app shows as follow:
.680: [FA:A0:BF:D2:F5:5F] problem while decoding Node statistics characteristic (0eb2bc59-baf1-4c1c-8535-8a0204c69de5), expecting multiplication of 8 bytes, remaining 60 instead, errorCode 10: GATT_REPRESENTATIONcom.decawave.argomanager.exception.GattCharacteristicDecodeException: problem while decoding Node statistics characteristic (0eb2bc59-baf1-4c1c-8535-8a0204c69de5), expecting multiplication of 8 bytes, remaining 60

Did you update the apk?

OOps… Its fixed by R2 app. Thanks Kenneth.

Hi Brock,
For some reason the compiler is not understanding the the * as a wildcard.
As a workaround we did the following, and it worked for us:

In the ‘Project Explorer’ pane of SES, right click on the Solution and select ‘Options…’
In the Code/External Build section is the Link Command. You will need to edit a part in the middle of this.
Find the snippet that says:
and edit it to say:
Leaving all the rest of the command as it is.

Hope it helps,

1 Like

Perfect! Works great, thank you @Ryan for the patch.

Now I’m up to the step of creating the hex file… the documentation is very windows-centric (.bat file in a utilities folder with some .exe’s there too).
Does anyone have directions for how to make a hex file under linux?

@Kenneth_Dwyer_DW, is my problem that the build process just isnt supported outside Windows, and that I should move to a windows machine to build my code? Since the earlier virtual box had ubuntu as the OS, I just assumed linux would be supported, but maybe that’s my problem. In any case, is there a plan to release an update with full linux support in the future?
Thanks -Brock

it’s possible to configure the raspberry proxy-server-host over HTTPS?
In /etc/dwm1001/dwm1001-proxy.config it can only change the server_host and server_port.
I need to use mqtt over TLS with X.509 self-signed certificates.


Hi Marco,

see this post to understand a bit the data chain:

Have you tried to configure the DWM Daemon and DWM Proxy to use the MQTT over TLS ports?
Please see the configuration in files

TLS can be enabled in the Mosquitto Broker configuration file:

I have not tried that but it should work.


can you please share the link?