DWM1001 not recognizing tag on app

Hi there!

I’m rather new to the Decawave modules, so I don’t really have much knowledge of how they work and how to operate. I use mostly the mobile app to check the positioning and a library that integrates that positioning with ROS on a computer. I’ve done successful tries in the past and there were no problem with them.

However, this time, I can’t get the tag to work for my life. All the anchors are recongnized without problem, I can see the signals, change the LED and all the configurations, but the tag position simply doesn’t appear anymore in the map grid the app provides, and it was appearing without problems months ago, no matter what I do. I’ve tried changing the update frequencies, I’ve tried changing the tags, nothing works.

What could be causing the problem? And could the tag be getting the right positioning, but just not showing in the app?

Regardless, thanks in advance!

my best guess is that the position of anchors has changed and the TN cannot calculate its position anymore.

Try to connect the tag to to the PC enter shell and run command “les”, then you should see measured distances and calculated position.