DWM1001/MDEK1001-DEv Kit Software/Compiler Issues

Hello, everybody,

I am currently working on the DWM1001 module and the MDEK1001 Development Kit as part of my bachelor thesis. I am studying the enclosed data sheets and have tried to install the necessary software according to the DWM1001 Firmware User Guide in section 3.2.2. The installation itself ran without problems. But when I tried to compile a User Application Example (dwm-simple) I got an error message. I have included a picture of the error message that appears in SEGGER Embedded Studio.
I would be very grateful if someone could help me to solve the problem.

Thank you very much!

Have you installed ARM toolchain for your windows machine ? As far as I can remember, DWM1001_DWM1001-DEV_MDEK1001_Sources_and_Docs_v9 expect to have gcc-arm-none-eabi-5_4-2016q3-20160926-win32.exe installed.

Hey, thank you for your contribution. I figured out what the error was. I had to change a line in the Link Command settings which can be found when you open the solution options and navigate to External Build. I had to change the following line:

After I changed that I was able to compile the project.