DWM1001 Gateway - DWM1001 to RPi interface not working

Hi, I have tried unsuccessfully to configure a DW1001 GW with a RPi. I have used the recommended RPi image, R2 flash on the DWM1001, and followed the dev guide configuration steps. I can connect via Minicom to /dev/serial0 but all I get is intermittent 01 flags - just like as if you connected with the incorrect serial settings (my minicom settings are 115200 8N1). This is happening with two DWM1001 cards. As an aside, the chip on the DWM1001 board gets pretty hot.

All and any help is gratefully received. Thanks

Try to connect with TeraTerm. Although sometimes it takes a few attempts. The main thing to remember is disconnect and reconnect USB cable, Start TeraTerm and set the port. Lots of time when you do it the port does not show anymore when you try to create New Connection. So you try the process again. Sometimes Duplicate Connection works…

Hi jdel21,

Have a look at this post:

The most common problem is the wrong version of the RPi or wrong solderd pins.

Thanks for your reply. I followed the thread that you referenced but I am no nearer a resolution. I switched DWM1001 cards in case it was a soldering issue and I also tried a second ribbon cable. I also confirmed that I have the correct FW and Raspian image.So still at base0 - cant see anchors or tags in the WebApp. Please take a look at the outputs that I see:

forum1.pdf (143.1 KB)

I must be doing something stupid as presumably many users have got this to work first time…This is my second day at this and am getting a little frustrated :frowning_face:- any help will be gratefully received :innocent:. Thanks in advance.

By the version of the RPI, i mean the hardware part not the firmware image.

Its an RPi 3 Model B v1.2

Hi John,

this post might help you:

From the forum1.pdf file it looks like the SPI communication between the DWM Kernel Module and DWM1001-DEV does not work. The most common issue seems to be due to incorrect soldering the header connector.


Hands Up - issue was down to my own stupidity. I had incorrectly assumed that a ribbon cable would provide a one to one connection between the RPi and the DWM1001. To use a ribbon cable one must solder the connector to the underneath side of the DWM1001. Thanks to all who replied to my initial query. BTW - my ‘reverse’ connection did not destroy the RPi or DWM1001 even though the DWM1001 SoC became extremely hot.

Hi John,

Ok, great to hear you have found out the issue!