DW3xxx Device Driver Lib Question

I can’t use the function in DW3xxx Device Driver Version 06.00.xx.

After running the function dwt_readdevid() , i will jump to the HardFault_Handler.

The linker script has changed to include this structure in the “.text” segment of memory like so:
. = ALIGN(4);
__dw_drivers_start = .;
__dw_drivers_end = .;

I use the STM32CubeIDE. The lib is dwt_uwb_driver-m4-hfp-6.0.7.a.

you have to “probe” the driver, to correctly initialize it. See the example code from Qorvo, fn() calked dwt_probe()

I have probed the driver. I run the fn() called dwt_probe() and it return DWT_ERROR.

Hi. I am facing the exact same issue that you described and I can see on other post that you solved the problem. Can you share how you did it?

I do not solved the problem, but i used zephyr-dw3000-decadriver later. It works fine.

Probably because I am using STM32CubeIDE on windows . I can use zephyr lib on linux.

Maybe you can try to compile the program on linux.

Thanks a lot!!! I will try