Connecting DWM1001 to Raspberry Pi 3 over header pins

I want to acquire coordinate data using a listener (Shell mode).
For Raspberry Pi 3 using header pins connection, i can not find the device named /dev/serial0,d[color=#333333][size=small][font=Tahoma, Verdana, Arial, sans-serif]oes anyone know what the problem is here?[/font][/size][/color]is there anything else i need to set up?
I have flashed the DWM1001 with factory image( /dwm/recovery/dwm1001-flash.hex).
[color=#333333][size=small][font=Tahoma, Verdana, Arial, sans-serif]Thanks.[/font][/size][/color]

Have you tried /dev/ttyS0 or /dev/ttyAMA0 if you’ve switched off BLE? You may also need to disable the Console.

[color=#000000][size=medium][font=UICTFontTextStyleBody]I can not use ttyS0 or ttyAMA0 in my Raspberry P3.[/font][/size][/color]
[color=#000000][size=medium][font=UICTFontTextStyleBody]But when i connect dwm1001 to Raspberry P3 with USB cable,i can use ttyAMC0 device,it is ok for me.[/font][/size][/color]
[color=#000000][size=medium][font=UICTFontTextStyleBody]thank you.[/font][/size][/color]


I’m not sure why you can’t use ttyAMA0 or ttyS0 - are they in use by something else on the Pi3 or are they causing an error in your code when you open them (what is the error?) or something else?

Sounds like you need to go back to basics and check things through - perhaps a terminal emulator on the Pi3 and open the connection on ttyS0 using (for example Minicom)

minicom -D /dev/ttyS0

then press return ONCE to get @… received back, leave for a second and press return TWICE quickly and you should get the DWM welcome screen ending with the dwm> prompt. That will prove, or not, if you are getting coms between the Pi3 and the DWM1001-DEV

What OS are you running on the Pi?

What are you writing your code in? Can you post an example of what you are trying that is failing?

Can you post up the contents of config.txt and commandline3.txt?

I think your problems lay in the two txt files above!!! Unless there is some mechanical or electrical problem on the Pi3 to DWM1001-DEV header of course.




Thanks to you I solved the problem.
I did not config the serial setting of Raspberry pi3 correct when using header connectting,
and there is no /dev/serial0 or /dev/ttyS0 device file exist at all in my Raspberry pi3.
After changing the default setting of com port, serial0 or ttyS0 became available.
Currently, i can acquire data normally using serial0 or ttyS0 device.
Thank you very much for helping me.

best regards sincerely.


Hi, that’s great news, I’m glad you were able to get it sorted. Good luck with your future endeavors.

I tried to connect one UWB antenna and my Raspberry Pi 3 like your attached picture.
I would like to send info from my raspberry to the antenna through SPI.
I’m trying to write a simple message to the SPI in python from Raspberry using spydev library.

import spidev spi = spidev.SpiDev(), 0) # means, /dev/spidev0.0 to_send = [0x01, 0x02, 0x03] spi.xfer(to_send)

And from the antenna’s side, the following code:

[code]volatile uint8 dataA[20] = {19, 18, 17, 16, 15, 14, 13, 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 11};
volatile uint8 dataB[20];

//dwt_writetodevice(0x21, 0, 20, &dataA[0]);
dwt_readfromdevice(0x21, 0, 20, &dataB[0]);[/code]

But in dataB I can’t see any changing…