Cannot Configure Gateway Correctly

Greetings all,

I have positively scoured this forum for answer to my questions, and I always seems to be coming up short somewhere in getting the DRTLS Web-Manager app to work on the RPI 3B.

I have made several attempts to solder the DWM-DEV, all of which can make successfully communicate over UART connection. I have flashed and re-flashed my nodes, tried firmware updates, flashed the raspi image, and verified the DWM-Daemon logs to make sure it is functioning correctly. The PANID’s are all the same, tried with the dwm1001.config file and using ‘nis’ on the bridge node itself.

I have basically tried every ingle fix I can find to get this app working and it still won’t even show the gateway! (Yelling at it has not worked, that fix I have tried many times)

The closest I have come to nailing down the issue is dmesg on the raspi console showing

$ dwm spi0.0 Bridge not responding
$ dwm spi0.0 reinitialize…
$ dwm spi0.0 bridge is not connected to UWB network
$ dwm spi0.0 bridge ok

which will occur with some frequency while the gateway is on.

I’m at a loss, and if someone could at least tell me I’m not that crazy, I would surely appreciate it!