3 phase inverter fails to simulate

I am trying to simulate a 3phase inverter circuit, but it is failing with a timestep too small error.

Not sure where I am going wrong, but I am able to simulate in LTSpice.

1 Like

Whats the point of that “gate driver” behavioral source?

Please upload your electronic circuit in Qspice format

I don’t remember why I originally did it that way. When I looked at the LTSpice version I had removed that behavioral source and drove the switch directly from the one in the control signals section.


With that removed the simulation still fails with a timestep to small error.

I am not able to upload the qspice file as a new user.
I do have the file on github here

I am not able to upload Qspice files as a new user. I tried to attach a link to the files on github but it has been flagged as spam.

Try to obscure the link a bit and post it here

Like www.git***hub.com/lalalala

try the .options directive

You may try this:

.options method=gear cshunt=1f gmin=1e-7

tried with the options directive
method=gear didn’t help, but with cshunt and gmin the simulation runs until 2ms before failing with timestep too small. That is a big improvement.

ps://gthb.cm/laporteb/electronics-sims/tree/main/Qspice/three%20phase%20inverter”

I will help to review it later.

Anyway,

  1. maybe you can replace the diode model with behavioral ideal model (you can define vfwd, ron, roff)
  2. since you dont use any deadtime you can remove the antiparallel diode.
  3. you can replace the behavior of the low side gate driver as V = 5 - V(hi)

Your can post a complete link, just not sure if new forum user allow to do it. Repost github link of your schematic file.
https://github.com/laporteb/electronics-sims/blob/main/Qspice/three%20phase%20inverter/three%20phase%20inverter.qsch

I run this circuit with Qspice80.exe instead of Qspice64.exe and can pass, let us know if Qspice can simulate your circuit correctly if this resolve your problem.

  • In Qspice : Edit > Preference
  • Deselect “Fast (less accurate) Math”

By the way, beware this GND is not connected. Zoom-in and you can see it disconnect.
image

I saw that Qspice80, but not sure what is it supposed to do. Can you please explain to me?

Thanks

Go through two reply from Mike in this post. Qspice80 uses 80bit math.

Running qspice from command line? - QSPICE - Qorvo Tech Forum

1 Like

@physicboy
I switched the diode with behavioral ideal model ron=.01, simulation completes now very fast. I haven’t removed the antiparallel diode or changed the low side gate driver. I would like to fix the control signals so there is a deadtime and no shoot through.

@KSKelvin
I fixed the ground that was disconnected. Without changing the diodes to ideal, the simulation fails when “Fast (less accurate) Math” is selected, it completes when deselected.