Very high DWM1001 current consumption in OFF+SLEEP mode

Hi Epenciso,

Yes, it is not possible to put the module totally to sleep when it is out of the network. PANS is expected to work automatically so it needs a certain period to detect when the Tag is back in the network.

Thanks for your inputs, we will think of some suitable solution but putting it totally to Off by default would not fit well for all applications.

To solve the issue it would require a customization of PANS. If that would be an option for you please contact me via a private message.

Cheers,
TDK

Hi Leapslabs,
Thanks for the answer.

However, maybe I have not explained my self. We do not like to have the module totally Off. Also, we think it is quite useful to wake up the module at certain periods to lookfor a network.

What we find ‘extrange’ is to have a current consumption larger than 280uA in betweeen these BLE wakeup periods. After a poll period and before the next one, why is not able the module to stay in an sleep state similar to the sleep state in normal low power (when the module has 12uA of current consumption)???. This is our remark. Actually, we find this total nonsense…

Regards
Epenciso

Hi Epenciso,

that’s is strange then. I believe we have not seen a such issue. We will verify this and let you know.

Thanks,
TDK

Hello Epensico

I am working with UART communication of DWM module and successful in communicating it with ESP8266. The data transfer is not 100% reliable however , the DWM gives the POS output. I have “lep” command in shell mode. Furthermore , I am trying to put UWB module to deep sleep mode for some time and then wake it up using only UART. I am currently using PANS R2 firmware in the UWB. You have mentioned some commands for offline , sleep and reset commands. I am afraid , i didn’t understand it well. Can you please explain it further on how I can use ESP8266 UART to put DWM into deep sleep mode and then wake it up after sometime. I am stuck on this topic for some time now and unable to find useful information anywhere other than this post. I hope you will respond soon with a solution.

Regards

Hi Leapslabs,
Have you been able to test this issue?

Regards
Epenciso

Hi Epenciso,

apologies, I didn’t get into it yet. I will try to get back to you this week.

Regards,
TDK

Hi Rick,

I will try to respond you regarding the low power mode.

When the module is in Tag Low Power (i.e. Responsive Mode is Off), the firmware will be most of the time in deep sleep. It will wake up periodically at the update rate to do the measurement, then to generate an interrupt and to go back to deep sleep again.

On a such interrupt event you can wake up the module, read the data out and then issue a sleep command. The available interfaces to do this is via UART/SPI or on-module UserApplication using PANS library. If you do not issue the sleep command, the module will stay awake and consumes more energy. Please see the API documentation for more information: https://www.decawave.com/dwm1001/api/

Similarily when you enter shell, the module will be awake. In order to go to sleep you need to issue command “quit”.

Cheers,
TDK

Thanks for your help.
Currently I am following the below method to achieve my desired goal. However, I am 90% successful.
I am using the DWM1001 in shell mode. I am using commands “nmt” and “nmo” to turn on and off the DWM. I take the position data in between using "lep: command!.I can see that the current consumption is 1.5mA during the off mode!. Isn’t it supposed to be in the microamps level as said in the documentation?
I can see that the "nmo " command completely turns off the DWM.

Hope to get a response as soon as possible.

Regards

Hi Rick,

in nmo mode the module does not go to deep sleep. It only keeps the UWB in offline mode.
If you want to use Low Power you need to use nmtl and let it control the module automatically.

Cheers,
TDK

Hi Ric
You need to configure the tag as low power with command ‘nmtl’, and then, quit the shell console with command ‘quit’. If you leave the console oppened it will consume about 1mA. If you do not set the tag as low power, the consumption will be also very high.

You can also use the movile App to set the tag as low power: just disable the responsive mode

Regards
Epenciso

1 Like

Hi Epenciso,

apologies for the late response. I can confirm your observation is correct. It is a bug in PANS. Thanks for the feedback!

To summarize the issue:

  1. Tag in low power mode with BLE enabled and is in range with the network - power management works correctly and the average current is ~15uA (with stationary detection enabled).
  2. Tag in low power mode with BLE enabled and is out of the network (it seeks for the network) - the average power consumption would be > 425 uA - this is a bug in PANS.

Solution options:

  1. Disable completely BLE on the Tags.
  2. In case BLE is necessary - then disable BLE when the node is out of the network and enable it again when being back.
  3. We have not investigated yet the exact cause of the issue but we can do some bugfix / customization if you need an update soon. Please contact us via https://www.leapslabs.com/ in that case.

Thanks,
TDK

Hi TDK,
My response was undeliverable.
Could you please send me your contact email.

Many thanks

Hi all.
Interesting post.

@leapslabs, you mention solution option 2, disable BLE when the node is out of network. How can that, be done automatically? Maybe with code in user space?
Any clue?
Thanks!
Ramiro

Hi,
I’m stuck with the communication between ESP8266 and DWM1001. I’ve tried so many things but I cannot reach to communicate both devices.

Could you explain (or share code) about how you communicate ESP and DWM via UART??

I’m looking forward your answer

Best regards,
Carlos

@leapslabs Do you plan to update the software to remove this bug, a BLE based search is a very good idea (battery wise) and it would be great to have that functionality. This bug combined with the fact that an out-of-network range tag keeps searching for UWB network and consumes high current even in low power mode is really limiting to developing a battery powered tag. Thanks!

Hi,

Yes, the issue is fixed. It will come with a new bug-fixes release. I cannot comment on the release date yet. Please follow the forums.

Cheers,
TDK

1 Like

Hi @leapslabs has any release been published with this bug fix? Thanks!

1 Like

Hi @leapslabs any updates on this issues and release date. Thanks!

1 Like

Hi @makcst
sorry we cannot comment this.

Cheers
JK

@leapslabs, as makcast we are awaiting the bug fix.
Regards.

1 Like