Third Party Model Import Fatal Error

In trying to import the model for the TI OPA1662-Q1 op-amp, I get this error:

Fatal error: Unknown subckt: x_h1•u1 n2992235•u1 n01 n2992151•u1 mid•u1 block_dc_h1_opa1662•u1-q1•u1

Many of the TI models break out subcircuits as:
.SUBCKT BLOCK_DC_H1_OPA1662-Q1 1 2 3 4
H_H1 3 4 VH_H1 1K
VH_H1 1 2 0V

But QSpice doesn’t seem able to parse this apart. I can open the part as an ASCII file and see that when I’ve imported it, all the the ‘sub’ subckts are properly imported.

Is this a user error? Bug?

(I tried providing the model as a .txt file, but I am too new a user, apologies.)

I believe QSPICE should be able to run the model. Please e-mail the model to

I’ve tried a variety of things to try and get through the Qorvo automatic filtering…
OPA1662-Q1.txt (18.6 KB)

Regardless, my ‘trust level’ was upgraded and I have attached the model for you here. Apologies if this is inconvenient.

I believe this problem is fixed now. But you do have to check the box “Include Entire File” if you are using automatic symbol generation.