Receive SFD timeout when configure 850K

I use TREK1000 to test 850K data rate, the dwt_config as below. But it not work and always report Receive SFD timeout. I tried to set sfdTO to 0, it’s same. But, if change nsSFD to 0, it work fine.
The DW1000 User Manual Table 21 recommend use non-standard 16 symbol SFD for 850K, where went wrong?

dwt_config_t config = {
    .chan           = 2,               /* Channel number. */
    .prf            = DWT_PRF_16M,     /* Pulse repetition frequency. */
    .txPreambLength = DWT_PLEN_256,    /* Preamble length. Used in TX only. */
    .rxPAC          = DWT_PAC16,       /* Preamble acquisition chunk size. Used in RX only. */
    .txCode         = 3,               /* TX preamble code. Used in TX only. */
    .rxCode         = 3,               /* RX preamble code. Used in RX only. */
    .nsSFD          = 1,               /* 0 to use standard SFD, 1 to use non-standard SFD. */
    .dataRate       = DWT_BR_850K,     /* Data rate. */
    .phrMode        = DWT_PHRMODE_STD, /* PHY header mode. */
    .sfdTO          = (257 + 16 - 16)  /* SFD timeout (preamble length + 1 + SFD length - PAC size). Used in RX only. */

Hi guojing,
Would you have the same SFD settings (nsFSD =0) on all the boards?
Also check some of the other registers like AGC_TUNE1, DRX_TUNE1b and DRX_TUNE2. They’d be depending on cannel/prf/preamble/datarate.

You can also set 2 boards up as an evk and set it up as 2 x 850kb/s nodes or test your sw against it. See presentation attached.
What you would need is PC decaranging executable software , which you can download in the evk software package available on our web

Have a look at the presentation and PC decaranging UM to see what you can do.
/DecaRanging_PC_User_Guide.pdf (1.7 MB) Using PC Decaranging With TREK.pdf (439.7 KB)

Kind regards