MDEK1001 Kit

Hi guys,

I’ve setup four DWM1001-dev devices as anchors (one is anchor initialiser -> ain(act,real,-) , the other three just anchors an(act,-,-)). I have a fifth DWM device setup as an active tag (tn(act,twr,np,le)). I first tested the system in VM using the minicom in UART shell mode. Running les command prints ranges from tag to each anchor and also the location solution. No problem!

I then did the same connecting the tag to my Raspberry Pi 3B (note: it’s not a 3B+). I connected the tag to the Pi via usb, ran the UART shell, issued the les command and got position back.

I then attempted to run the example script provided; tag_cfg executable (following procedure outlined in of Firmware User Guide). Upon running the executable, I get the following error: “Unable to open UART […] UART: Ensure it is not in use by another application” (first attached file). Fine, I thought, I’ll try connecting to to the Pi via the headers (the same setup as figure 9 of the Firmware User Guide). I get exactly the same error.

I then tried to communicate to it in UART shell mode using minicom (connecting to serial0 as per of Firmware User guide) over header connection (figure 9). The shell opens, but it keeps trying to send the string Ubuntu, second attachment.

Does anyone have any suggestions as to why I can’t connect to it over UART using the API example, and why it has this strange behaviour in UART shell mode over header connection?

I tried to connect over SPI, and it appears to be working (although the anchors, excluding initialiser, powers off after a few seconds).

Thanks for your help,

1 Like

Hi Oliver,

It really looks like the UART is already open in another instance and they are both trying to access the uart. Have you close it properly after your first trial ?

Let me know how it goes, i’ll try to give it a go on my side.


1 Like

Hi Yves,

Have you had any luck trying this? There’s still no progress on my end. How can I ensure UART is closed on serial0?

I’m trying to track two tags attached to a UAV, connected to a RaspPi. In my mind, there could be three options:

  1. Connect both tags over SPI and use chip select to toggle between them to get data (possible?)
  2. Connect one over SPI the other over UART (again, is this possible?)
  3. Add a passive listener atop the Raspberry Pi to get location data from the two tags (this would be least desirable because of added weight of third DWM1001-dev board needed). Is there example api code which can take in the location from multiple tags and feed to to the Pi?


1 Like